Bug 490951 - Application runs out of X resources
Application runs out of X resources
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.7
All Linux
urgent Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Patch, Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 12:58 EDT by Olivier Fourdan
Modified: 2013-03-03 21:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Program creating many X resource might reach the maximum number of resource the X server can create. Consequence: Program reach maximum number of X resource might not work properly or refuse to run or work with degraded performances. Fix: By lowering the maximum number of X client we can increase the maximum number of X resource a program can create. Result: Program can create enough X resource to work smoothly and efficiently.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-16 09:32:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (9.41 KB, patch)
2009-04-21 08:24 EDT, Olivier Fourdan
no flags Details | Diff
Proposed patch (11.51 KB, patch)
2009-04-22 07:30 EDT, Olivier Fourdan
no flags Details | Diff
Proposed fix (11.53 KB, patch)
2009-04-22 08:01 EDT, Olivier Fourdan
no flags Details | Diff

  None (edit)
Comment 4 Olivier Fourdan 2009-04-21 08:24:42 EDT
Created attachment 340509 [details]
Proposed patch

This patch is a mix of Adam's patch and the one I worked on.

The main difference is that it keeps MAXCLIENTS as a static define because it's used in different places for the size of various arrays (and also because it potentially reduces the impact of patch, MAXCLIENTS remains as it was)

So, instead, MAXCLIENTS is still the maximum possible, and the user can select a lower value (64, 128, 256 or 512) that affects the amount of bits used between clients and resources.

The patch also includes the code for the command line option (-maxclients) and an xorg.conf option in the "ServerFlags" section.

e.g.:

  Section "ServerFlags"
          Option      "MaxClients" "128"
  EndSection

The patch also includes the changes for the man pages.

I also made the same patch for EL5 and current git for xserver.

Tests were made by using the tests programs mentionned before and by launching as many X clients as possible until the limit is reach. Might need more testing though.
Comment 9 Olivier Fourdan 2009-04-22 07:30:01 EDT
Created attachment 340718 [details]
Proposed patch

Updated patch, this patch fixes an issue with the Xorg.conf "MaxClients" option and adds a message in the log.
Comment 10 Olivier Fourdan 2009-04-22 08:01:27 EDT
Created attachment 340721 [details]
Proposed fix

Updated patch, typo.
Comment 11 Olivier Fourdan 2009-04-23 04:51:11 EDT
Just for clarification, this patch assumes and depends on the previous patch that increased MAXCLIENT to 512 (xorg-x11-6.8.2-maxclients.patch introduced in 6.8.2-1.EL.25)
Comment 19 Adam Jackson 2011-01-24 22:46:49 EST
Devel ack
Comment 21 Jérôme Glisse 2011-01-25 13:31:54 EST
https://brewweb.devel.redhat.com/taskinfo?taskID=3062565

3062565 build
Source: cvs://cvs.devel.redhat.com/cvs/dist?rpms/xorg-x11/RHEL-4#xorg-x11-6_8_2-1_EL_65
Build Target: dist-4E-qu-candidate
Completed successfully
Comment 23 Florian Nadge 2011-01-26 13:06:02 EST
Please be so kind and add a few key words to the Technical Note field of this
Bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks
Comment 24 Florian Nadge 2011-01-26 13:06:02 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:
Comment 25 Jérôme Glisse 2011-01-28 09:55:40 EST
Added technical notes.
Comment 26 Jérôme Glisse 2011-01-28 09:55:40 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,15 @@
 Cause:
 
+Program creating many X resource might reach the maximum number of resource the X server can create.
+
 Consequence:
 
+Program reach maximum number of X resource might not work properly or refuse to run or work with degraded performances.
+
 Fix:
 
-Result:+By lowering the maximum number of X client we can increase the maximum number of X resource a program can create.
+
+Result:
+
+Program can create enough X resource to work smoothly and efficiently.
Comment 31 errata-xmlrpc 2011-02-16 09:32:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0254.html

Note You need to log in before you can comment on or make changes to this bug.