Bug 490966 - anaconda exception reformatting existing LV
anaconda exception reformatting existing LV
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:220baac8a0a0b9bbd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 13:33 EDT by G.Wolfe Woodbury
Modified: 2009-06-25 11:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 11:36:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (189.16 KB, text/plain)
2009-03-18 13:33 EDT, G.Wolfe Woodbury
no flags Details
Attempt1 install to existing LVM Fedora-11-Snap1-i686-Live-KDE (671.63 KB, text/plain)
2009-04-13 11:22 EDT, Ronald L Humble
no flags Details

  None (edit)
Description G.Wolfe Woodbury 2009-03-18 13:33:27 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.31 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 671, in create
    raise FSError("filesystem already exists")
  File "/usr/lib/anaconda/storage/deviceaction.py", line 280, in execute
    options=self.device.formatArgs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 629, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 184, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
FSError: filesystem already exists
Comment 1 G.Wolfe Woodbury 2009-03-18 13:33:35 EDT
Created attachment 335740 [details]
Attached traceback automatically from anaconda.
Comment 2 G.Wolfe Woodbury 2009-03-18 18:17:23 EDT
attempting to reuse existing LVs during an install.
Comment 3 Joel Andres Granados 2009-04-02 09:42:32 EDT
This report is against an anaconda that is quite old.  We are currently in anaconda 11.5.0.39 and you tested with 11.5.0.31.  A lot of code has gone in to address FS handling.  Can you pls retest wit current anaconda rawhide and see if this issue is still present.
Comment 4 Ronald L Humble 2009-04-13 11:22:16 EDT
Created attachment 339328 [details]
Attempt1 install to existing LVM Fedora-11-Snap1-i686-Live-KDE

Fedora-11-Snap1-i686-Live-KDE install failed; worse than fc11 Beta; No install
Attachment is from four attempts marked by **** END ****
A) Create Custom Layout
B) edit existing ext4 whi_root LVM partition; format to ext4;repeated for whi_usr, whi_var
C) dialog stating will destroy all data; Select "Format"; Select "Write changes to disk" --> exception created

Second attempt (after reboot): A)
Select whi_root -> Edit --> immediate exception (2nd on list)

Third attempt made without reboot --> exception NOT attached

Fourth attempt(after reboot): A) B)
 Noticed three above LVM partitions were listed as Unknown (not ext<3 4>)
Likely was case for attempt #2 and #3; did not notice
As in attempt #2 Select whi_root -> Edit --> immediate exception (3nd on list)

Fifth attempt: same dual boot machine - booted to fc10 and formatted 
whi_<root usr var> partitions as ext3 and checked by mounting. Boot to LIVE CD.
Install went as with attempt #1; "Write changes to disk" --> exception

Good luck ladies and gentlemen - RoyBoy626
Comment 5 David Lehman 2009-04-23 19:01:45 EDT
(In reply to comment #4)
> Created an attachment (id=339328) [details]
> Attempt1 install to existing LVM Fedora-11-Snap1-i686-Live-KDE
> 
> Fedora-11-Snap1-i686-Live-KDE install failed; worse than fc11 Beta; No install
> Attachment is from four attempts marked by **** END ****
> A) Create Custom Layout
> B) edit existing ext4 whi_root LVM partition; format to ext4;repeated for
> whi_usr, whi_var
> C) dialog stating will destroy all data; Select "Format"; Select "Write changes
> to disk" --> exception created
> 

The first and last exceptions both show a failure to resize an LV, yet you make no mention of having elected to resize any LVs. In any case, all of the failures you have reported are unrelated to the original problem reported here. Please, if you are still experiencing these failures, file a bug for each distinct failure you encounter so that we can track each problem individually.
Comment 6 David Lehman 2009-04-23 19:04:45 EDT
I have done several installs to new filesystems on existing LVs. I'm marking this one modified until/unless someone has seen a failure since the beta.
Comment 7 Bug Zapper 2009-06-09 08:21:55 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.