Bug 49103 - xircom network card not working with pcmcia
xircom network card not working with pcmcia
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-13 14:19 EDT by Jp Robinson
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 13:09:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jp Robinson 2001-07-13 14:19:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows 98; Win 9x 4.90)

Description of problem:
pcmcia startup seems to go ok, I can load the module for the card (it 
loads automatically as well, just fine). It seems to recognize the card 
and even mentions it's hwaddr, however it does not let eth0 come up. Card 
worked ok before now but is failing with pcmcia version 3.1.27-5. 
Card is a Xircom CE3-10/100 Fast Ethernet, Laptop is a Dell Inspiron 3500, 
cardbus: Texas Instruments PCI1220 rev 02
/etc/sysconfig/pcmcia looks ok (refers to yenta_socket with the opts lines 
blank as they were under 7.1).



How reproducible:
Always

Steps to Reproduce:
1.Attempt to bring up eth0 and get: failed; no link present
2.
3.
	

Additional info:
Comment 1 Glen Foster 2001-07-13 18:16:26 EDT
This defect considered SHOULD-FIX for Fairfax gold-release.
Comment 2 Jp Robinson 2001-07-17 14:52:27 EDT
Additional info:  
The bus works with a Dlink card, so it seems to reside in the driver for the card. 
? 
I do not have link lights (or other lights) when the driver loads and talks to
the card. Cable is good, dongle is good, all working in windows ME on same laptop
Comment 3 Arjan van de Ven 2001-08-20 09:05:52 EDT
Does it work if you replace "xircom_cb" with "xircom_tulip_cb" ?
Comment 4 Jp Robinson 2001-08-24 13:08:57 EDT
The machine has since been upgraded to Roswell. The card is detected properly
and works properly under Roswell. If you would like, I can revert the machine to
beta 2 and try the different drivers, Although I'm guessing Roswell counts as
"fixed"?
Comment 5 Arjan van de Ven 2001-08-24 13:17:01 EDT
That's fixed in my book

Note You need to log in before you can comment on or make changes to this bug.