Bug 491047 - Click on [HELP] displays "Not found"
Click on [HELP] displays "Not found"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 02:48 EDT by Jan ONDREJ
Modified: 2010-09-04 06:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 05:36:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2009-03-19 02:48:28 EDT
Description of problem:
Clicking HELP link on bugzilla page displays Not found, because there is no help for unknown language. Documentation is in /en/ subdirectory.

Version-Release number of selected component (if applicable):
bugzilla-3.2.2-2.fc10.noarch
bugzilla-doc-3.2.2-2.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. open bugzilla
2. click on "HELP" link
  
Actual results:
Not Found

The requested URL /bugzilla/docs/html/query.html was not found on this server.
Apache/2.2.10 (Fedora) Server at stats.upjs.sk Port 443

Expected results:
Doc page.

Additional info:
You can avoid this by adding an alias for docs without specified language.

Alias /bugzilla/docs/html /usr/share/bugzilla/docs/en/html
Alias /bugzilla /usr/share/bugzilla

Aliases have to be in this order. It works for me and avoids problems with pages, which specifies language in URL.
Comment 1 Jan ONDREJ 2009-05-19 05:36:01 EDT
Looks that this is fixed in bugzilla-3.2.3.
Closing bug.
Comment 2 Joel Uckelman 2010-09-03 17:49:36 EDT
I'm having this same problem with bugzilla-3.4.8-2.fc13.noarch.

I think whatever was fixed in 3.2.3 has since come unfixed. Maybe this bug should be reopened?
Comment 3 Jan ONDREJ 2010-09-04 03:20:57 EDT
Looks like problem is on your side. Try to install bugzilla-doc package, then it will work. Use this command:

  yum install bugzilla-doc
Comment 4 Joel Uckelman 2010-09-04 06:39:09 EDT
That's most definitely not the problem. I have the bugzilla-doc package installed. The docs aren't missing. The URL BZ gives in it's help links just isn't right.

Note You need to log in before you can comment on or make changes to this bug.