Bug 491081 - Dependency breakage since recent gnome-bluetooth updates
Dependency breakage since recent gnome-bluetooth updates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpodder (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 07:19 EDT by Trustin Lee
Modified: 2009-03-20 20:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 20:03:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trustin Lee 2009-03-19 07:19:49 EDT
Description of problem:

  'yum upgrade' fails with dependency resolution failure when gpodder is installed.

Version-Release number of selected component (if applicable):

  gpodder-0.14.1-2.fc11.noarch

How reproducible:

  Always

Steps to Reproduce:
1. yum upgrade
  
Actual results:

  Failed upgrade

Expected results:

  Successful upgrade

Additional info:

[trustin@vault ~]$ sudo yum upgrade --disableplugin=*
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: bluez-gnome for package: gpodder
---> Package gnome-bluetooth.x86_64 0:2.27.1-4.fc11 set to be updated
--> Processing Dependency: obexd for package: gnome-bluetooth
--> Processing Dependency: bluez for package: gnome-bluetooth
--> Processing Dependency: libgnome-bluetooth.so.2()(64bit) for package: gnome-bluetooth
--> Running transaction check
---> Package bluez.x86_64 0:4.32-8.fc11 set to be updated
--> Processing Dependency: bluez-gnome for package: gpodder
---> Package gnome-bluetooth-libs.x86_64 0:2.27.1-4.fc11 set to be updated
---> Package obexd.x86_64 0:0.8-2.fc11 set to be updated
--> Finished Dependency Resolution
gpodder-0.14.1-2.fc11.noarch from installed has depsolving problems
  --> Missing Dependency: bluez-gnome is needed by package gpodder-0.14.1-2.fc11.noarch (installed)
Error: Missing Dependency: bluez-gnome is needed by package gpodder-0.14.1-2.fc11.noarch (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 1 Jef Spaleta 2009-03-20 19:52:29 EDT
are you still getting this?

rawhide appears to have the bluez-gnome-0:1.8-16.fc11 package today.


-jef
Comment 2 Jef Spaleta 2009-03-20 20:03:29 EDT
Okay confirmed and fixed. I'm rolling out gpodder 0.15.1 with and the packaging fix together.

-jef

Note You need to log in before you can comment on or make changes to this bug.