This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 491082 - unresolvable dependency in kdebase-workspace-4.2.1-10.fc11
unresolvable dependency in kdebase-workspace-4.2.1-10.fc11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 07:39 EDT by Mamoru TASAKA
Modified: 2009-03-19 08:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 08:18:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2009-03-19 07:39:33 EDT
Description of problem:

[root@localhost System]# yum --disablerepo=\* --enablerepo=koji-11 -y upgrade kde\*
Loaded plugins: dellsysidplugin2
Setting up Upgrade Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package kdebase-workspace.i586 0:4.2.1-10.fc11 set to be updated
--> Processing Dependency: ksysguardd = 4.2.1-10.fc11 for package: kdebase-workspace
--> Processing Dependency: kdm = 4.2.1-10.fc11 for package: kdebase-workspace
---> Package kdebase-workspace-devel.i586 0:4.2.1-10.fc11 set to be updated
---> Package kdebase-workspace-libs.i586 0:4.2.1-10.fc11 set to be updated
--> Processing Dependency: kdelibs4(x86-32) >= 4.2.1 for package: kdebase-workspace-libs
---> Package kdelibs.i586 6:4.2.1-7.fc11 set to be updated
---> Package kdelibs-common.i586 6:4.2.1-7.fc11 set to be updated
---> Package kdelibs-devel.i586 6:4.2.1-7.fc11 set to be updated
--> Running transaction check
---> Package kdebase-workspace-libs.i586 0:4.2.1-10.fc11 set to be updated
--> Processing Dependency: kdelibs4(x86-32) >= 4.2.1 for package: kdebase-workspace-libs
---> Package kdm.i586 0:4.2.1-10.fc11 set to be updated
--> Processing Dependency: kdelibs4(x86-32) >= 4.2.1 for package: kdm
---> Package ksysguardd.i586 0:4.2.1-10.fc11 set to be updated
--> Finished Dependency Resolution
kdebase-workspace-libs-4.2.1-10.fc11.i586 from koji-11 has depsolving problems
  --> Missing Dependency: kdelibs4(x86-32) >= 4.2.1 is needed by package kdebase-workspace-libs-4.2.1-10.fc11.i586 (koji-11)
kdm-4.2.1-10.fc11.i586 from koji-11 has depsolving problems
  --> Missing Dependency: kdelibs4(x86-32) >= 4.2.1 is needed by package kdm-4.2.1-10.fc11.i586 (koji-11)
Error: Missing Dependency: kdelibs4(x86-32) >= 4.2.1 is needed by package kdm-4.2.1-10.fc11.i586 (koji-11)
Error: Missing Dependency: kdelibs4(x86-32) >= 4.2.1 is needed by package kdebase-workspace-libs-4.2.1-10.fc11.i586 (koji-11)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):
kdebase-workspace-4.2.1-10.fc11

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.
Comment 1 Rex Dieter 2009-03-19 08:18:36 EDT
Coulda swore I added that Provides to kdelibs, but can't find it now.  
Ah, didn't commit/build yet (oops).  Doing so now in kdelibs-4.2.1-8

Note You need to log in before you can comment on or make changes to this bug.