Bug 491115 - GUI quirks
GUI quirks
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xarchiver (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On: 489402
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 10:21 EDT by Michal Nowak
Modified: 2013-03-07 21:05 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.5.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 15:08:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 5130 None None None Never

  None (edit)
Description Michal Nowak 2009-03-19 10:21:37 EDT
Description of problem:

• Xarchiver -> Help -> Thanks to -> "Nonsence_here"
• [missing icon] Xarchiver -> Preferencies -> Archive
• Xarchiver -> Preferencies -> Archive -> Preferred archive format -> arj
  -> why arj? bz2 or zip are better IMO

Version-Release number of selected component (if applicable):

xarchiver-0.5.2-3.fc11.x86_64
Comment 1 Christoph Wickert 2009-03-19 12:20:51 EDT
(In reply to comment #0)
> • Xarchiver -> Help -> Thanks to -> "Nonsence_here"

The idea is that people sponsor the development and therfor get mentioned in this menu. I have been arguing with upstream quite a while about this and I'm tired now. If you dislike it too, file a bug upstream, because the more people we are the better our chances get.

> • [missing icon] Xarchiver -> Preferencies -> Archive

I do have an icon there. What icon theme are you using?

> • Xarchiver -> Preferencies -> Archive -> Preferred archive format -> arj
>   -> why arj? bz2 or zip are better IMO

xarchiver detects the installed programs and arj is simply the first when ordered alphabetically. I will try to look into that.
Comment 2 Michal Nowak 2009-03-19 12:50:01 EDT
(In reply to comment #1)
> The idea is that people sponsor the development and therfor get mentioned in
> this menu. I have been arguing with upstream quite a while about this and I'm
> tired now. If you dislike it too, file a bug upstream, because the more people
> we are the better our chances get.

http://bugzilla.xfce.org/show_bug.cgi?id=5130 but I wouldn't mind here Fedora's specific change to proper label it as "Donate", or dumping that sub-menu at all.

> I do have an icon there. What icon theme are you using?

GNOME, but happens for any icon set. No error msg produced.

> xarchiver detects the installed programs and arj is simply the first when
> ordered alphabetically. I will try to look into that.  

Understand. Please, do.
Comment 3 Christoph Wickert 2009-03-22 19:36:25 EDT
Ok, fixed arj and the menu, the icon is still outstanding. Please give me a
  find /usr/share/icons/ -name gnome-mime-application-zip*
Comment 4 Michal Nowak 2009-03-23 04:00:39 EDT
Thanks!

newman@dhcp-lab-124 Desktop $ find /usr/share/icons/ -name gnome-mime-application-zip*
/usr/share/icons/Rodent/48x48/mimetypes/gnome-mime-application-zip.png
/usr/share/icons/Rodent/scalable/mimetypes/gnome-mime-application-zip.svg
Comment 5 Christoph Wickert 2009-03-23 10:04:21 EDT
Ok, this explains what you see. The problem is that the names in rodent and Gnome, Mist, Fedora etc don't match: gnome-mime-application-zip vs. package-x-generic.png

We need to fix bug 489402.
Comment 6 Christoph Wickert 2009-04-17 15:08:55 EDT
I have build xarchiver-0.5.2-4 for F-11 and rawhide. Default archive format now is bz2, donators menu is removed and the icon issue was fixed in bug # 489402. Closing
Comment 7 Fedora Update System 2009-06-14 10:09:21 EDT
xarchiver-0.5.2-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xarchiver-0.5.2-4.fc11
Comment 8 Fedora Update System 2009-06-24 15:29:21 EDT
xarchiver-0.5.2-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.