Bug 491207 - Anaconda crashes trying to retrieve kickstart file via nfs
Anaconda crashes trying to retrieve kickstart file via nfs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 15:53 EDT by Orion Poplawski
Modified: 2009-04-29 21:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 21:06:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-03-19 15:53:44 EDT
Description of problem:

Today's (20090319) rawhide.

This may be limited to this hardware as a similar install on a xen guest started okay.

loader received SIGSEGV! Backtrace:
loader(loadSegvHandler)
libc
loader(doPwMount)
loader(getFileFromNfs)
loader(getKickstartFile)
loader(main)

VT3:
INFO : file location: nfs:saga:/export/data1/ks/rawhide-laptop64.cfg

Pinging the machine while it came up, did get two responses before it crashed.
No record of mount attempt in nfs server log.

2 for 2 on this machine now.
Comment 1 Chris Lumens 2009-03-19 16:25:12 EDT
David's already got a line on this one.
Comment 2 Orion Poplawski 2009-03-19 17:17:56 EDT
I don't know if this is related, but in the xen install that booted okay, I go the following in my %post script:

+ mkdir -p /data/backup1
+ mount -v saga:/export/backup1 /data/backup1
mount: no type was given - I'll assume nfs because of the colon
mount.nfs: timeout set for Thu Mar 19 14:36:02 2009
mount.nfs: text-based options: 'addr=192.168.0.12'
saga:/export/backup1 on /data/backup1 type nfs (rw)
+ mkdir -p /nfs/local
+ mount -v earth:/export/local /nfs/local
mount: no type was given - I'll assume nfs because of the colon
mount.nfs: mount(2): Input/output error
mount.nfs: mount system call failed
mount.nfs: timeout set for Thu Mar 19 14:36:02 2009
mount.nfs: text-based options: 'addr=192.168.0.8'

Running system is capable of mounting earth:/export/local fine.

earth is CentOS 5.2, saga is Fedora 10.
Comment 3 Orion Poplawski 2009-03-20 10:47:31 EDT
Okay, the crash has been fixed.  I now see:

Error downloading kickstart file

Running tshark on the nfs server I see no traffic from the install machine.  I can ping it though.  Changing to FQDN does not help. 

VT3:

doing kickstart... setting it up
get_connection (2051): NetworkManager connected
url is saga:/export/data1/ks/rawhide-laptop64.cfg
file location: nfs:saga:/export/data1/ks/rawhide-laptop64.cfg
ERROR: failed to mount nfs source
Comment 4 David Cantrell 2009-04-29 21:06:19 EDT
With the latest nightly tree, I cannot reproduce this issue.  I am able to pass:

ks=nfs:HOSTNAME:/path/to/ks.cfg

The interface is brought up with dhcp, the kickstart file is downloaded, and installation begins.

Note You need to log in before you can comment on or make changes to this bug.