Bug 491216 - mdadd failed for /dev/sdd3
mdadd failed for /dev/sdd3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 17:17 EDT by W Agtail
Modified: 2009-04-23 14:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 14:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg file (2.73 KB, application/octet-stream)
2009-03-19 17:17 EDT, W Agtail
no flags Details
anaconda log from rawhide install via pxe (82.08 KB, text/plain)
2009-03-23 15:47 EDT, W Agtail
no flags Details
anaconda log from rawhide install via pxe with USB media card reader disabled (81.84 KB, text/plain)
2009-03-24 17:31 EDT, W Agtail
no flags Details

  None (edit)
Description W Agtail 2009-03-19 17:17:11 EDT
Created attachment 335933 [details]
ks.cfg file

Description of problem:
I am able to install F11 Alpha OK. However, after the install the system reboots and fails to start up. I have attached my kickstart file, which I copy to a usb flash drive as /ks.cfg.

Version-Release number of selected component (if applicable):
Fedora-11-Alpha-x86_64-DVD.iso

How reproducible:
Always.

Steps to Reproduce:
1. Boot from Fedora-11-Alpha-x86_64-DVD.iso DVD image.
2. Install via kickstart by appending. ks=hd:sdc1:/ks.cfg
  
Actual results:
Install runs through OK, but fails to boot after the install. The error message is:
mkrootdev: expected fs options
mount: missing mount point

Expected results:
Install and reboot into F11.

Additional info:
sha1sum passed and the media check passed.
Comment 1 W Agtail 2009-03-23 15:46:48 EDT
I've been trying out raw hide today via PXE and using an interactive install.
Anaconda bails out. I have 2 sata hard drives. I'm not sure why they are being detected as sda & sdd, I would expect sda & sdb.

Find attached anaconda.log. Thanks
Comment 2 W Agtail 2009-03-23 15:47:56 EDT
Created attachment 336365 [details]
anaconda log from rawhide install via pxe
Comment 3 Chris Lumens 2009-03-23 16:13:31 EDT
anaconda 11.5.0.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/mdraid.py", line 144, in mdadd
    raise MDRaidError("mdadd failed for %s" % device)
  File "/usr/lib/anaconda/storage/devices.py", line 2177, in _addDevice
    mdraid.mdadd(device.path)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1187, in addUdevDevice
    md_array._addDevice(device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1475, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 239, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 64, in storageInitialize
    anaconda.id.storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
MDRaidError: mdadd failed for /dev/sdd3
Comment 4 Chuck Ebbert 2009-03-23 18:14:36 EDT
sdb and sdc are:

<5>scsi 0:0:0:0: Direct-Access     VIA-P    VT6205-DevB      2.82 PQ: 0 ANSI: 2
<5>scsi 0:0:0:1: Direct-Access     VIA-P    VT6205-DevM      2.82 PQ: 0 ANSI: 2

The vt6205 is some kind of card reader controller. Can you try disabling that in the system BIOS?
Comment 5 W Agtail 2009-03-24 17:29:59 EDT
Thank you for your time with this. vt6205 is a USB media card reader which i have now disabled. I just tried a pxe install with same error. See attached ana2.log.
Comment 6 W Agtail 2009-03-24 17:31:21 EDT
Created attachment 336548 [details]
anaconda log from rawhide install via pxe with USB media card reader disabled
Comment 7 W Agtail 2009-04-01 16:35:20 EDT
Hi
FYI I have just tried Fedora-11-Beta-x86_64-DVD.iso via kickstart. Pre Installation script runs through now, however the following error message is displayed while parsing the kickstart configuration:
Specified nonexistent partition sdb1 in partition command.

Which refer to:
part raid.12 --onpart=sdb1

The previous line to this is:
part raid.11 --onpart=sda1

Running fdisk /dev/sdb from [alt] F2 screen confirms /dev/sdb1 with an ID of 83.

Any ideas? Thanks.
Comment 8 W Agtail 2009-04-17 11:56:48 EDT
Hi
With the attached kickstart file in mind: h-f11-ks.cfg
I have tried today's rawhide and have got a little further.
The error message now displayed is:
Tried to use undefined partition pv.4 in Volume Group specification

which refers to the following line in the kickstart file:
volgroup sys --pesize=32768 pv.4

Regards
Comment 9 Chris Lumens 2009-04-23 14:00:20 EDT
Sounds like your original problem is now solved, and we already have another bug plus patch for your new issue so I'm going to close this one out as resolved.  Thanks for the testing.

Note You need to log in before you can comment on or make changes to this bug.