Bug 491224 - Fix the channel cloning to point to its original channels comps info
Fix the channel cloning to point to its original channels comps info
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Red Hat Satellite QA List
Depends On: 249376
Blocks: 462714
  Show dependency treegraph
Reported: 2009-03-19 17:54 EDT by Pradeep Kilambi
Modified: 2014-05-09 06:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-05-09 06:38:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2009-03-19 17:54:44 EDT
The old way of getting comps to work for cloned channels was to hack in a fix to point to original channel comps file in the python code. Since thats now deprecated, this should be done at the channel cloning time in the perl code by adding an entry into rhnChannelComps tables (instead of an ugly hack whcih is not used any more as its old repomd code).

Should be a simple fix, need to look for the original channel id, lookup comps info and point that to this new cloned channel id.
Comment 15 Clifford Perry 2014-05-09 06:38:13 EDT
We have not addressed this specific bug in over 5 years years. This does not seem to have an active customer case with the bug report either. Closing out as wontfix to clear from backlog. 

Please re-open if you disagree and wish further review.


Note You need to log in before you can comment on or make changes to this bug.