Bug 491230 - end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 18:37 EDT by Thomas Meyer
Modified: 2009-03-22 17:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-22 17:51:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
init from initrd (1.73 KB, text/plain)
2009-03-19 18:40 EDT, Thomas Meyer
no flags Details

  None (edit)
Description Thomas Meyer 2009-03-19 18:37:19 EDT
Description of problem:
I see this messages in dmesg in the boot process:

[    3.936279] Write protecting the kernel read-only data: 3576k
[    4.000260] Clocksource tsc unstable (delta = -77010480 ns)
[    4.219021] end_request: I/O error, dev fd0, sector 0

-> Here I need to enter my password for disk decryption.

[   25.763030] end_request: I/O error, dev fd0, sector 0
[   26.298030] end_request: I/O error, dev fd0, sector 0
[   27.521031] end_request: I/O error, dev fd0, sector 0
[   28.064809] EXT4-fs: barriers enabled
[   28.067738] kjournald2 starting: pid 1271, dev dm-0:8, commit interval 5 seconds
[   28.067756] EXT4-fs: delayed allocation enabled
[   28.067761] EXT4-fs: file extents enabled
[   28.069202] EXT4-fs: mballoc enabled
[   28.069208] EXT4-fs: mounted filesystem dm-0 with ordered data mode

I'm not sure who's responsible for this (senseless?) accesses, but these seems to completely happen in initrd, i.e. before mounting real root.

Is this a bug or feature?

Version-Release number of selected component (if applicable):
udev.x86_64                      139-2.fc11
nash.x86_64                      6.0.81-1.fc11
busybox.x86_64                   1:1.13.2-2.fc11 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Meyer 2009-03-19 18:40:07 EDT
Created attachment 335939 [details]
init from initrd
Comment 2 Harald Hoyer 2009-03-20 04:09:40 EDT
if this is happening in initrd, then nash is to be blamed.
Comment 3 Hans de Goede 2009-03-20 04:22:22 EDT
Thomas,

Do you by any chance have an IDE floppy drive? Or do you have built your own
kernel? The classic floppy driver is a module and thus is not present when
the initrd gets executed, so no way these messages can come from the initrd with
a Fedora provided kernel.
Comment 4 Thomas Meyer 2009-03-22 17:33:24 EDT
> Do you have built your own kernel?

Yes. Indeed, I do. With build-in floppy driver, no module.

So I guess the above described behaviour is a feature ;-)
Comment 5 Hans de Goede 2009-03-22 17:51:38 EDT
(In reply to comment #4)
> > Do you have built your own kernel?
> 
> Yes. Indeed, I do. With build-in floppy driver, no module.
> 
> So I guess the above described behaviour is a feature ;-)  

Yes, could be caused by lvm or by specifying root (in the kernel cmdline, through grub.conf) as UUID= or LABEL=, lvm will scan all block devices (although it may skip floppies) for physical volumes and specifying root as UUID= / LABEL= will cause nash to scan all block devices to find the UUID / LABEL.

You could try working around this by specifying your root= as /dev/.... in grub.conf

Closing this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.