Bug 491234 - livecd-iso-to-disk shouldn't ask to overwrite boot loader
livecd-iso-to-disk shouldn't ask to overwrite boot loader
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 19:07 EDT by Warren Togami
Modified: 2009-07-21 14:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 14:31:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-03-19 19:07:04 EDT
livecd-tools-022-1.fc11
syslinux-3.73-2.fc11
mtools-4.0.9-1.fc11

Use livecd-iso-to-disk with on a USB stick already written previously by livecd-iso-to-disk.

Updating boot config file
Installing boot loader
file is read only, overwrite anyway (y/n) ? 

Processes running at this time:
/usr/bin/livecd-iso-disk --noverify --skipcopy --reset-mbr livecd.iso /dev/sdb1
syslinux -d syslinux /dev/sdb1
mmove -D o -D O s:/ldlinux.sys s:/syslinux/ldlinux.sys

There is no good reason for the program to ask for permission to overwrite this file.  It seems that mtools changed to prompt instead of just go ahead.

I couldn't figure out how to use mattrib to unprotect ldlinux.sys prior to syslinux tries to install it again.
Comment 1 Jeremy Katz 2009-03-20 10:48:11 EDT
Fixed in git, although the fix is ugly.
Comment 2 Warren Togami 2009-04-05 00:30:56 EDT
I just noticed this still happens in rawhide, was this not built into rawhide yet?
Comment 3 Jeremy Katz 2009-04-06 10:08:41 EDT
Has there been a new livecd-tools build since the 20th? (answer: no)

I'll get a build before the devel freeze, but this is hardly critical enough on its own to have warranted special builds
Comment 4 Bug Zapper 2009-06-09 08:25:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jeremy Katz 2009-07-21 14:31:25 EDT
Closing out bug that's been in MODIFIED for a while.

Note You need to log in before you can comment on or make changes to this bug.