Bug 491238 - connection to dead network not dropped
connection to dead network not dropped
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 20:17 EDT by Tomasz Torcz
Modified: 2009-03-23 14:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 14:19:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2009-03-19 20:17:10 EDT
Description of problem:
Problem I'm experiencing is not typical and frankly, I'm not sure if fixable, even by modifing drivers. I have my laptop connected by wired ethernet to desktop computer. Desktop computer has two ethernet cards bridged together. My laptop connects automatically to wi-fi network available and to wired network also. Wired is preferred.
Now, when I shutdown desktop computer following happens. Bridged networks cease to work, of course. But for some reason network card in desktop stays powered up, so network card in laptop doesn't experience link loss. So switch to wifi network doesn't happen. Wired network is treated as active and connectivity suffers.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0.99-3.fc10.x86_64

How reproducible:
Always
Comment 1 Dan Williams 2009-03-23 12:44:53 EDT
What do you get for the output of:

sudo /sbin/ethtool eth0

If you see:

Link detected: yes

then the card is reporting a carrier, and NM will obviously keep the connection up because the cable is still plugged in.

It's not unusual for machines these days to keep the PHY powered up (and thus you'd have a link) for Wake-on-LAN functionality.  If that's the case, then you're pretty much out of luck, and you'll need to disconnect the cable because there's no good way of immediately figuring out whether the remote system is still there.
Comment 2 Tomasz Torcz 2009-03-23 13:59:40 EDT
That's exactly the situation:

% sudo /sbin/ethtool kabel | grep Link
	Link detected: yes

And I think this situation is futile. The only solutions I can think of require pinging or arpinging the gateway or some similar stupid, poll-happy solution. Maybe if I wait until DHCP refresh time come...
Feel free to close this bug, as there is really no good solution.
Comment 3 Dan Williams 2009-03-23 14:19:00 EDT
Ok, thanks.

Note You need to log in before you can comment on or make changes to this bug.