Bug 491281 - Software Channel Entitlement Counts listing does not match RHN Satellite List Page Size
Software Channel Entitlement Counts listing does not match RHN Satellite List...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Shannon Hughes
Preethi Thomas
:
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-03-20 04:11 EDT by Jan Pazdziora
Modified: 2009-09-10 15:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-03-20 04:11:39 EDT
Description of problem:

The Software Channel Entitlement Counts was showing records 1--20 of 32. I thought I'd change the number of records on page. So I went to Your Preference page, and was surprised to find RHN Satellite List Page Size set to 5, not 20.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090306.2 on i386

How reproducible:

Tried once.

Steps to Reproduce:
1. Compare number of records in Admin > Organizations > Subscriptions > Software Channel Entitlements with RHN Satellite List Page Size value in Overview > Your Preference.
  
Actual results:

20 records on page, RHN Satellite List Page Size saying 5.

Expected results:

20 records on page, RHN Satellite List Page Size saying 20;
or 5 records on page, RHN Satellite List Page Size saying 5.

Additional info:
Comment 1 Shannon Hughes 2009-03-24 16:28:15 EDT
this works for me. tried several different pagination values. i also tried the software entitlements pages under a specific org to make sure we were not confusing the two pages. 

lets retest this.
Comment 2 Preethi Thomas 2009-04-20 10:47:22 EDT
looks like this is working 
tested in
Satellite-5.3.0-RHEL5-re20090414.0-i386-embedded-oracle.iso
Comment 3 John Matthews 2009-07-30 16:06:58 EDT
Moving to RELEASE_PENDING

verified that I can change the number of items to display on:  /rhn/channels/software/Entitlements.do
value placed in preferences is correct
Comment 4 Brandon Perkins 2009-09-10 15:48:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.