Bug 491296 - Segmentation fault when start guest with pcidevice
Segmentation fault when start guest with pcidevice
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Chris Wright
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 05:41 EDT by Yolkfull Chow
Modified: 2016-04-26 10:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 01:52:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trace message from dmesg (1.68 KB, text/plain)
2009-04-13 01:34 EDT, Yolkfull Chow
no flags Details

  None (edit)
Description Yolkfull Chow 2009-03-20 05:41:33 EDT
Description of problem:
Found following segmentation fault in demsg when using command : #qemu-kvm r53c32nfs.img -m 512 -smp 2 -pcidevice host=00:1d.0 to start the guest:

qemu-kvm[8516]: segfault at 0000000000000018 rip 00000000004a8a82 rsp 00007fffa5c5c870 error 4

Version-Release number of selected component (if applicable):
83-20
kernel :  2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
cpu: Intel(R) Core(TM)2 Duo CPU     E6550

How reproducible:
twice


Steps to Reproduce:
1. #qemu-kvm r53c32nfs.img -m 512 -smp 2 -pcidevice host=00:1d.0
2.
3.
  
Actual results:
Found segmentation fault error in dmesg

Expected results:
No segmentation fault error.

Additional info:
Comment 1 Yaniv Kaul 2009-03-20 06:39:07 EDT
Yingfu,

If it's reproducible, why not attach gdb to the process and see where it fails? Add kvm-debuginfo package, and you've made the developer's life much easier.
Comment 2 Yolkfull Chow 2009-04-13 01:34:24 EDT
Created attachment 339277 [details]
trace message from dmesg

Yaniv, attachment is the trace message from dmesg on host, sorry for attach it a little late. :)

There is no backtrace in gdb since it did not crash the guest,which means although we can find the trace message in dmesg on host, the guest is running well.

The command I used:
#qemu-kvm /tmp/kvm_autotest_root/images/RHEL-Server-5.3-64.qcow2 -smp 4 -pcidevice host=00:1c.0 -m 1000

Tested kvm pkg: 83-28
Comment 3 Dor Laor 2009-04-16 03:51:41 EDT
pci passthrough is not supported for rhev (only for rhel 5.4)
btw: there is no kvm rpm ver.
Can you close the bug?
Comment 4 RHEL Product and Program Management 2009-04-16 04:05:18 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 5 Lawrence Lim 2009-04-16 14:36:40 EDT
RE: comment #3, 

llim->yzhou, please create the bug against RHEL5.4
Comment 6 Yolkfull Chow 2009-04-16 23:19:21 EDT
(In reply to comment #3)
> pci passthrough is not supported for rhev (only for rhel 5.4)
> btw: there is no kvm rpm ver.
> Can you close the bug?  

Hi Dor, I had added kvm rpm version when the bug was opened:

--------
Version-Release number of selected component (if applicable):
83-20   <<<<<<<<<<< version is here

kernel :  2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64
x86_64 GNU/Linux
cpu: Intel(R) Core(TM)2 Duo CPU     E6550
--------

Ok, Lawrence, I will create it against 5.4. Thank you! :)
Comment 7 jason wang 2009-04-17 01:28:58 EDT
Dor:
   Does the configuration flags needed by PCI-passthrough (such as CONFIG_DMAR) is turned on in RHEL5.4 or there is some others flags used to do this? I could not found any flags related to passthrough in current kernel of RHEL 5.4(2.6.18.138.el5).
Comment 8 Lawrence Lim 2009-04-17 07:17:34 EDT
Support for PCI pass through is a feature for Version 2.0 so this is a bug which has to be fixed. Reopen bug n adjust flag.
Comment 9 RHEL Product and Program Management 2009-06-22 14:47:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 10 Eduardo Habkost 2010-01-20 06:51:50 EST
On RHEL-6, the KVM userspace package is named "qemu-kvm". Moving bug to the right component.
Comment 12 Qunfang Zhang 2010-04-09 05:40:23 EDT
This issue is not found in qemu-kvm-0.12.1.2-2.36.el6.x86_64, so setting status to verified.

Note You need to log in before you can comment on or make changes to this bug.