Bug 491339 - Previous RAID install causes anaconda failure
Previous RAID install causes anaconda failure
Status: CLOSED DUPLICATE of bug 489745
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 10:20 EDT by James Laska
Modified: 2013-09-02 02:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 10:46:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-logs.tgz (syslog, anaconda.log, program.log, storage.log) (17.46 KB, application/octet-stream)
2009-03-20 10:20 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-20 10:20:16 EDT
Created attachment 336053 [details]
anaconda-logs.tgz (syslog, anaconda.log, program.log, storage.log)

Description of problem:


Version-Release number of selected component (if applicable):
anaconda-11.5.0.34

How reproducible:
everytime

Steps to Reproduce:
1. Install RHEL5 raid5 in a virt guest
2. Start manual install of rawhide in same virt guest
  
Actual results:

* The install appears to hang over VNC, but closer inspection of the root console shows ...

13:57:50 Starting VNC...                                                       
13:57:51 The VNC server is now running.
13:57:51 

WARNING!!! VNC server running with NO PASSWORD!
You can use the vncpassword=<password> boot option
if you would like to secure the server.


13:57:51 Please manually connect your vnc client to test1125.test.redhat.com:1 (192.168.34.125) to begin the install.
Press <enter> for a shell
Xlib:  extension "RANDR" missing on display ":1.0".
Xlib:  extension "RANDR" missing on display ":1.0".
13:57:52 Starting graphical installation...
Backtrace has 20 calls on stack:
  20: /lib64/libparted-1.8.so.8(ped_assert+0x8a) [0x7fa277a8f40a]
  19: /lib64/libparted-1.8.so.8 [0x7fa277a93283]
  18: /lib64/libparted-1.8.so.8 [0x7fa277a948c8]
  17: /lib64/libparted-1.8.so.8(ped_disk_remove_partition+0xeb) [0x7fa277a94ddb]
  16: /usr/lib64/python2.6/site-packages/_pedmodule.so(py_ped_disk_remove_partition+0xe8) [0x7fa276806c22]
  15: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5313) [0x7fa2868ff3c3]
  14: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x8b3) [0x7fa286901063]
  13: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x56f8) [0x7fa2868ff7a8]
  12: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x8b3) [0x7fa286901063]
  11: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x56f8) [0x7fa2868ff7a8]
  10: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  9: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  8: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  7: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  6: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  5: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  4: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x8b3) [0x7fa286901063]
  3: /usr/lib64/libpython2.6.so.1.0 [0x7fa28688e62f]
  2: /usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53) [0x7fa286863cb3]
  1: /usr/lib64/libpython2.6.so.1.0 [0x7fa286878fff]
Backtrace has 20 calls on stack:
  20: /lib64/libparted-1.8.so.8(ped_assert+0x8a) [0x7fa277a8f40a]
  19: /lib64/libparted-1.8.so.8 [0x7fa277a93283]
  18: /lib64/libparted-1.8.so.8(ped_disk_add_partition+0x292) [0x7fa277a95e82]
  17: /lib64/libparted-1.8.so.8 [0x7fa277abd5bb]
  16: /lib64/libparted-1.8.so.8 [0x7fa277abd6de]
  15: /lib64/libparted-1.8.so.8 [0x7fa277a9490c]
  14: /lib64/libparted-1.8.so.8(ped_disk_remove_partition+0xeb) [0x7fa277a94ddb]
  13: /usr/lib64/python2.6/site-packages/_pedmodule.so(py_ped_disk_remove_partition+0xe8) [0x7fa276806c22]
  12: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5313) [0x7fa2868ff3c3]
  11: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x8b3) [0x7fa286901063]
  10: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x56f8) [0x7fa2868ff7a8]
  9: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x8b3) [0x7fa286901063]
  8: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x56f8) [0x7fa2868ff7a8]
  7: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  6: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  5: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  4: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  3: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  2: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x66a5) [0x7fa286900755]
  1: /usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x8b3) [0x7fa286901063]


Expected results:


Additional info:
Comment 1 Joel Andres Granados 2009-03-20 10:46:50 EDT

*** This bug has been marked as a duplicate of bug 489745 ***

Note You need to log in before you can comment on or make changes to this bug.