Bug 49135 - src compilation problem
src compilation problem
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-15 04:49 EDT by Nicolas CROISET
Modified: 2007-04-18 12:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-08 07:35:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas CROISET 2001-07-15 04:49:56 EDT
Description of Problem:
When I want to compil php-4.0.6-2.src.rpm, I have this error message :

checking whether to enable maintainer-specific portions of Makefiles... no
checking host system type... i686-pc-linux-gnu
checking for gawk... gawk
checking for bison... bison -y
checking bison version... 1.28 (ok)
checking for gcc... gcc
checking whether the C compiler (gcc -O2 -march=i386 -mcpu=i686 -fPIC ) works...
 no
configure: error: installation or configuration problem: C compiler cannot create executables.
Bad exit status from /var/tmp/rpm-tmp.79461 (%build)

How Reproducible:
I am under Redhat 7.0 with gcc 2.96-85

Steps to Reproduce:
1. rpm --rebuild php-3.0.6-2.src.rpm
Comment 1 Nicolas CROISET 2001-08-15 04:59:58 EDT
Hello,

I had test one times again to compil under redhat 7.0 and I obtain this. If I made the ./configure directly with no patch I have no error.
------------------
rpm --rebuild php-4.0.6-3.src.rpm
Installing php-4.0.6-3.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.91323
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf php-4.0.6
+ /bin/mkdir -p php-4.0.6
+ cd php-4.0.6
+ /bin/gzip -dc /usr/src/redhat/SOURCES/php-4.0.6.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ pushd php-4.0.6
/usr/src/redhat/BUILD/php-4.0.6/php-4.0.6 /usr/src/redhat/BUILD/php-4.0.6
+ echo 'Patch #0 (php-4.0.6-redhat.patch):'
Patch #0 (php-4.0.6-redhat.patch):
+ patch -p1 -b --suffix .redhat -s
+ echo 'Patch #1 (php-4.0.3-required.patch):'
Patch #1 (php-4.0.3-required.patch):
+ patch -p1 -b --suffix .required -s
+ echo 'Patch #2 (php-4.0.4pl1-linkage.patch):'
Patch #2 (php-4.0.4pl1-linkage.patch):
+ patch -p1 -b --suffix .linkage -s
+ echo 'Patch #3 (php-4.0.6-libtool.patch):'
Patch #3 (php-4.0.6-libtool.patch):
+ patch -p1 -b --suffix .libtool -s
+ echo 'Patch #4 (php-4.0.5-db.patch):'
Patch #4 (php-4.0.5-db.patch):
+ patch -p1 -b --suffix .db -s
+ echo 'Patch #5 (php-4.0.5-ext.patch):'
Patch #5 (php-4.0.5-ext.patch):
+ patch -p1 -b --suffix .ext -s
+ cp Zend/LICENSE Zend/ZEND_LICENSE
+ ln -s /usr/include ext/imap/
+ mkdir ext/imap/lib
+ cp -fv /usr/lib/c-client.a ext/imap/lib/libc-client.a
/usr/lib/c-client.a -> ext/imap/lib/libc-client.a
+ ./buildconf
buildconf: checking installation...
buildconf: autoconf version 2.13 (ok)
buildconf: automake version 1.4 (ok)
buildconf: libtool version 1.3.5 (ok)
rebuilding Makefile templates
rebuilding configure
rebuilding main/php_config.h.in
+ popd
/usr/src/redhat/BUILD/php-4.0.6
+ cp -a php-4.0.6 php-4.0.6-cgi
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.15734
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd php-4.0.6
+ krb5libs=-L/usr/kerberos/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err
+ ssllibs=-lssl -lcrypto
+ sasllibs=-lsasl -L/usr/kerberos/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err
-lssl -lcrypto
+ CFLAGS=-O2 -march=i386 -mcpu=i686 -fPIC
+ export CFLAGS
+ LIBS=-lttf -lfreetype -lpng -ljpeg -lz
+ export LIBS
+ REDO_ALL=yes
+ export REDO_ALL
+ EXTENSION_DIR=/usr/lib/php4
+ export EXTENSION_DIR
+ pushd php-4.0.6-cgi
/usr/src/redhat/BUILD/php-4.0.6/php-4.0.6-cgi /usr/src/redhat/BUILD/php-4.0.6
+ compile --enable-force-cgi-redirect
+ ./configure --prefix=/usr --with-config-file-path=/etc --disable-debug --enable-pic --enable-inline-optimization --enable-force-cgi-redirect --with-dom --with
-exec-dir=/usr/bin --with-regex=system --with-gettext --with-gd --with-jpeg-dir=/usr --with-png --with-ttf --with-zlib --with-db3 --with-gdbm --with-openssl --w
ith-layout=GNU --enable-debugger --enable-magic-quotes --enable-safe-mode --enable-sockets --enable-sysvsem --enable-sysvshm --enable-track-vars 
--enable-yp --enable-ftp --enable-wddx --without-mysql --without-unixODBC --without-oracle --wi
thout-oci8 --with-pspell --with-xml
creating cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
Updated php_version.h
checking whether to enable maintainer-specific portions of Makefiles... no
checking host system type... i686-pc-linux-gnu
checking for gawk... gawk
checking for bison... bison -y
checking bison version... 1.28 (ok)
checking for gcc... gcc
checking whether the C compiler (gcc -O2 -march=i386 -mcpu=i686 -fPIC ) works...
 no
configure: error: installation or configuration problem: C compiler cannot create executables.
Bad exit status from /var/tmp/rpm-tmp.15734 (%build)
Comment 2 Nicolas CROISET 2001-09-15 10:58:59 EDT
The problem is the same with the php-4.0.6-6.src.rpm
Comment 3 Nicolas CROISET 2001-10-27 05:53:47 EDT
Hello, I had test also in 4.0.6-9, and th eprobleme is the same. But I have more
infinformations.

in the subdirectory php4.0.6-cgi there is a config.log with more informations.
-------------------
configure:1829: checking whether the C compiler (gcc -O2 -march=i386 -mcpu=i686
-fPIC ) works
configure:1845: gcc -o conftest -O2 -march=i386 -mcpu=i686 -fPIC   conftest.c -l
ttf -lfreetype -lpng -ljpeg -lz -lnsl 1>&5
/usr/bin/ld: cannot find -lfreetype
collect2: ld returned 1 exit status
configure: failed program was:

#line 1840 "configure"
#include "confdefs.h"

main(){return(0);}
----------------------
The compiler does not find freetype, but these RPM's are installed yet.

freetype-devel-1.3.1-7
freetype-1.3.1-7


which is the solution ?
Comment 4 Nicolas CROISET 2001-10-28 03:47:24 EST
Hello,

I have found the problem : in the SPEC file there is a line :
LIBS="-lttf -lfreetype -lpng -ljpeg -lz -lnsl"; export LIBS

In this line I delete -lfreetype, and then the compilation works without problems.

Comment 5 Phil Copeland 2002-01-08 12:03:31 EST
Hi, I just took over control of the php package. Is this a problem specfically
for 7.0?

Have you tried the
ftp://rawhide.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/php-4.0.6-13.src.rpm
package and gotten the same results?

Phil
=--=
Comment 6 Nicolas CROISET 2002-01-08 12:40:59 EST
Hello,

No, when I made the test only php-4.0.6-9.src.rpm was exist.

I will make the test with this new relase.
Comment 7 Nicolas CROISET 2002-01-11 15:38:59 EST
Hello,

it's not very easy to compile the src RPM now (php-4.0.6-13.src.rpm) with the
command --rebuild, there is a lot of dependencies where I can't find RPm for
redhat 7.0.

rpm --rebuild php-4.0.6-13.src.rpm
Installing php-4.0.6-13.src.rpm
error: failed build dependencies:
        apache(EAPI)-devel is needed by php-4.0.6-13
        gd-devel >= 2.0.1 is needed by php-4.0.6-13
        libltdl-devel >= 1.4 is needed by php-4.0.6-13
        libmcrypt-devel >= 2.4.4 is needed by php-4.0.6-13
        libtool >= 1.4 is needed by php-4.0.6-13
        mhash-devel is needed by php-4.0.6-13
        ming-devel >= 0.1.0 is needed by php-4.0.6-13
        pdflib-devel >= 4.0.0 is needed by php-4.0.6-13
        t1lib-devel is needed by php-4.0.6-13
        openssl-devel >= 0.9.6a is needed by php-4.0.6-13
I search these RPM with Rpmfind, but there is a lot not compatible with redhat 7.0.
Comment 8 Johannes Erdfelt 2002-02-06 14:04:07 EST
The problem appears to be the older version of freetype used on RH 7.0 vs RH 7.2.

RH 7.0 shipped with freetype 1.3, RH 7.2 shipped with 2.0 which includes
libfreetype.

Installing freetype 2.0 solves this problem for me.

Perhaps the BuildPreReq should specify freetype >= 2.0.0 or similar?
Comment 9 Nicolas CROISET 2002-02-08 07:35:04 EST
Yes it's OK for me now.
Comment 10 Peter Bowen 2002-04-15 21:58:48 EDT
The appears to be fixed according to reporter's last comment.

Note You need to log in before you can comment on or make changes to this bug.