Bug 49138 - Some screensavers cannot be run as non-root: permission denied
Summary: Some screensavers cannot be run as non-root: permission denied
Status: CLOSED DUPLICATE of bug 47069
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-15 10:35 UTC by Telsa Gwynne
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-15 10:35:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Telsa Gwynne 2001-07-15 10:35:50 UTC
Description of Problem:

Playing with screensavers through the gnome control-centre capplet.

xscreensaver: could not execute "atlantis": permission denied.
xscreensaver: could not execute "bubble3d": permission denied.
xscreensaver: could not execute "glplanet": permission denied.

I am running X as non-root.

I expect this has something to do with it.

[hobbit@pwca xscreensaver]$ pwd; ls -l | grep -- "----"
/usr/X11R6/lib/xscreensaver
-rw-------    1 root     root            0 Jun 24 23:49 atlantis
-rw-------    1 root     root            0 Jun 24 23:49 bubble3d
-rw-------    1 root     root            0 Jun 24 23:49 dangerball
-rw-------    1 root     root            0 Jun 24 23:49 gflux
-rw-------    1 root     root            0 Jun 24 23:49 glplanet
-rw-------    1 root     root            0 Jun 24 23:49 gltext
-rw-------    1 root     root            0 Jun 24 23:49 lament
-rw-------    1 root     root            0 Jun 24 23:49 molecule
-rw-------    1 root     root        90112 Jun 24 23:49 morph3d
-rw-------    1 root     root            0 Jun 24 23:49 pulsar
-rw-------    1 root     root            0 Jun 24 23:49 rubik
-rw-------    1 root     root            0 Jun 24 23:49 sierpinski3d
-rw-------    1 root     root            0 Jun 24 23:49 starwars
-rw-------    1 root     root       122880 Jun 24 23:49 stonerview

Why are most of these apparently empty?

[hobbit@pwca xscreensaver]$ rpm -V xscreensaver
..?.....   /usr/X11R6/lib/xscreensaver/atlantis...
(same for all of those listed above: because I ran rpm as non-root?)

Comment 1 Bill Nottingham 2001-07-15 23:49:59 UTC
Argh, that reminds me, I need to actually build 3.33-1. :)

*** This bug has been marked as a duplicate of 47069 ***


Note You need to log in before you can comment on or make changes to this bug.