Bug 491410 - IRQ routing problems seen when using qla4xxx driver, during and after install
IRQ routing problems seen when using qla4xxx driver, during and after install
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 16:19 EDT by Kris Strecker
Modified: 2014-07-08 23:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:16:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL 5.2 Inbox driver (37.68 KB, application/x-zip-compressed)
2009-03-20 16:28 EDT, Kris Strecker
no flags Details
RHEL 5.2 with Qla4xxx 5.01.03.04 driver (56.60 KB, application/x-zip-compressed)
2009-03-20 16:29 EDT, Kris Strecker
no flags Details
RHEL 5.2 with Qla4xxx 5.01.03.04 driver and "irqpoll" added to boot option (68.94 KB, application/x-zip-compressed)
2009-03-20 16:31 EDT, Kris Strecker
no flags Details
RHEL 5.2 with Qla4xxx 5.01.03.04 driver and 2.6.18-128.1.1 Errata Kernel (105.19 KB, application/x-zip-compressed)
2009-03-20 16:40 EDT, Kris Strecker
no flags Details
RHEL 5.2 with Qla4xxx 5.01.03.04 driver, and using without-usb in mkinitrd (76.79 KB, application/x-zip-compressed)
2009-03-20 16:41 EDT, Kris Strecker
no flags Details

  None (edit)
Description Kris Strecker 2009-03-20 16:19:43 EDT
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB5; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.1; .NET CLR 3.0.04506.648)

When using the Qlogic QLe4062c iSCSI HBA, if both ports have been enabled to have boot from SAN support (i.e. they have an IP address, and are configured to boot from a LUN), the OS will report IRQ problems when the driver loads.  This causes the second port of the the Qlogic card to not log into the target correctly.  This is both during install and after install.  I have seen this issue on HP DL380G5 and HP BL460c servers (both Intel 5000P chipsets).  It does not seem to happen on AMD based products, but I can not say that for certain.  I do not know if it occurs on other Intel based systems.

Reproducible: Always

Steps to Reproduce:
1.  Install a Qlogic 4062c iSCSI HBA into a DL380 G5 server, or a QHM4062 iSCSI Mezz card into a BL460c blade server.
2.  Configure both ports on the card to do iSCSI boot in the BIOS.  Verify that you can indeed log into the iSCSI target from both ports in the BIOS.
3.  Install RHEL 5.2.
Actual Results:  
During install, you will see only one device to install to.  After install is complete, only one port of the Qlogic card will log into the target.  This can be seen on the target as well as in the OS, since there will only be one scsi host with any connections.

Expected Results:  
There should be two devices shown at install time, as well as two devices shown after the OS is running.  This would allow for multipathing the boot device.

We have seen that if the configuration is what is shown above, there will be a call stack in the dmesg file when the driver is loading.  The call stack is around the IRQs that the card is using.  In dmesg, it states using "irqpoll" to work around the issue.  We have tried the "irqpoll" option during install and during regular operation, and it does seem to allow the second port to log in sucessfully, but IRQPOLL will slow down performance.
We have tried this with the latest errata kernel (2.6.18-128) and the problem remains.
We have also been in contact with Qlogic, but they claim this is a IRQ routing problem in the kernel.
Comment 1 Kris Strecker 2009-03-20 16:28:31 EDT
Created attachment 336112 [details]
RHEL 5.2 Inbox driver

This file shows the output from dmesg, /proc/interrupts, /var/log/messages, and /etc/grub.conf with the RHEL 5.2 inbox driver.
Comment 2 Kris Strecker 2009-03-20 16:29:54 EDT
Created attachment 336113 [details]
RHEL 5.2 with Qla4xxx 5.01.03.04 driver

This file shows the output from dmesg, /proc/interrupts, /var/log/messages, and /etc/grub.conf with the latest Qlogic driver (5.01.03.04).
Comment 3 Kris Strecker 2009-03-20 16:31:11 EDT
Created attachment 336115 [details]
RHEL 5.2 with Qla4xxx 5.01.03.04 driver and "irqpoll" added to boot option

This file shows the output from dmesg, /proc/interrupts, /var/log/messages, and /etc/grub.conf with the latest Qlogic driver (5.01.03.04), and adding "irqpoll" to the boot option
Comment 4 Kris Strecker 2009-03-20 16:40:46 EDT
Created attachment 336116 [details]
RHEL 5.2 with Qla4xxx 5.01.03.04 driver and 2.6.18-128.1.1 Errata Kernel

This file contains output with the latest Errata kernel (2.6.18-128.1.1)
Comment 5 Kris Strecker 2009-03-20 16:41:59 EDT
Created attachment 336117 [details]
RHEL 5.2 with Qla4xxx 5.01.03.04 driver, and using without-usb in mkinitrd

This file contains information after recreating the initrd with the --without-usb option.
Comment 6 RHEL Product and Program Management 2014-03-07 07:46:56 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:16:45 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 8 Kris Strecker 2014-07-08 23:34:52 EDT
Ok this bug is over 5 years old, nothing was ever done with it, so please close it.

Note You need to log in before you can comment on or make changes to this bug.