This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 491420 - Regression: with latest kernel kernel, plymouth takes text-mode plugin instead of solar plugin
Regression: with latest kernel kernel, plymouth takes text-mode plugin instea...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 17:10 EDT by Davide Cescato
Modified: 2009-03-25 15:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 15:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Cescato 2009-03-20 17:10:34 EDT
Description of problem:

Since the latest kernel update plymouth no longer works in graphical mode (solar plugin), but only in text mode (with the text-mode progress bar).
The kernel command line is 

kernel /boot/vmlinuz-2.6.29-0.258.rc8.git2.fc11.x86_64 ro root=UUID=f901
0aa2-aa2b-47ef-ba0d-08bd10f2239d quiet acpi_osi="Linux" rhgb

If I reboot and select the previous kernel version, with the command line

kernel /boot/vmlinuz-2.6.29-0.237.rc7.git4.fc11.x86_64 ro root=UUID=f901
0aa2-aa2b-47ef-ba0d-08bd10f2239d quiet acpi_osi="Linux" rhgb

the problem does not occur, and plymouth displays the solar animation.


Version-Release number of selected component (if applicable):

2.6.29-0.258.rc8.git2.fc11.x86_64


How reproducible:
always


Steps to Reproduce:
1. reboot and select kernel 2.6.29-0.258.rc8.git2.fc11.x86_64 with the command line given above


Actual results:

1. The text-mode plymouth starts while the screen is still in the 80-columns text mode; the beginning of the blue progress bar appears at the bottom of the screen
2. A fraction of second later, kernel modesetting successfully kicks in; the blue progress bar is now in the upper half of the screen and keeps growing
3. Booting continues with text-mode plymouth until gdm successfully starts


Expected results:

After kernel modesetting kicks in, plymouth runs with the solar plugin until gdm starts.


Additional info:

Smolt profile at
http://www.smolts.org/client/show/pub_2033d145-e24b-4057-9bfc-e7fb427a8c73
Comment 1 Davide Cescato 2009-03-25 15:58:42 EDT
With kernel-2.6.29-0.258.2.3.rc8.git2.fc11.x86_64, the bug no longer occurs. Good for F11 Beta!

Closing.

Note You need to log in before you can comment on or make changes to this bug.