Bug 491440 - xorg is using the vesa driver - ugh! (f10->rawhide upgrade problem)
xorg is using the vesa driver - ugh! (f10->rawhide upgrade problem)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 20:31 EDT by Need Real Name
Modified: 2009-05-27 05:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 05:33:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-03-20 20:31:49 EDT
I have an Iiyama ProLite E2201W monitor with an Intel graphics card.
Smolt profile here: http://www.smolts.org/client/show/pub_1f537efb-3ace-44a1-bef6-d3bd92eb4a08

X no longer starts. Running s-c-d gives me a horrific stretched screen due to it choosing vesa. Everything worked perfectly in F10.
Comment 1 Matěj Cepl 2009-04-24 17:24:09 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Need Real Name 2009-04-24 18:17:18 EDT
Sure, see bug 496335.
Comment 3 Matěj Cepl 2009-04-26 04:43:03 EDT
(In reply to comment #2)
> Sure, see bug 496335.  

XOrg.0.log is attachment 339892 [details]
Comment 4 Adam Jackson 2009-05-26 18:31:43 EDT
That X log looks like a successful startup to me.  What does it look like when it fails?
Comment 5 Need Real Name 2009-05-27 01:53:50 EDT
Yep it works now. The bug may still exist (f10->rawhide upgrade fails) but I have no way of testing that anymore.
Comment 6 Matěj Cepl 2009-05-27 05:33:12 EDT
OK, so let's call this bug closed. If you have any further problems, please, file a separate bug then (and don't forget to attach the same logs as described in comment 1).

Thank you helping us with Rawhide

Note You need to log in before you can comment on or make changes to this bug.