Bug 491460 - Audio input stopped working after recent updates.
Audio input stopped working after recent updates.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: alsa-lib (Show other bugs)
5.5
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Jaroslav Kysela
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-21 07:10 EDT by Audrius Meskauskas
Modified: 2009-10-07 08:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 08:10:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsamixer -c 0 (41.03 KB, image/png)
2009-03-28 05:30 EDT, Audrius Meskauskas
no flags Details
alsamixer -c 0 other s (34.41 KB, image/png)
2009-03-28 05:31 EDT, Audrius Meskauskas
no flags Details

  None (edit)
Description Audrius Meskauskas 2009-03-21 07:10:32 EDT
Description of problem:
The audio input that has never been a problem have recently stopped working. The audio hardware is functional as the sound is captured normally under Windows boot on the same machine. The microphone is activated in Kmix and switching the microphone on/off produces a weak noise in the loudspeaker. The sound output is working properly and it is possible to hear the test sound in the configuration tool.

It is possible to hear the output from the Skype, but the input is not captured. The recording level indicator in the Krec also does not move.

This bug is important as it breaks Skype that is needed for us.

Version-Release number of selected component (if applicable):
Linux localhost.localdomain 2.6.18-128.1.1.el5 #1 SMP Mon Jan 26 13:58:24 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Unsure. Check if it works for you with the recent updates. 

Steps to Reproduce:
1. Try Skype test call.
2. Try Kmix
  
Actual results:
1. Skype test call replays your message after the beep.
2. Kmix recording level indicator moves; Kmix captures the input.


Expected results:
1. Skype seems not capturing any sound input.
2. Kmix recording level indicator does not move; Kmix seems capturing the dead silence.




Additional info:
Comment 1 Jaroslav Kysela 2009-03-23 05:38:14 EDT
Please, attach information from 'alsa-info.sh --no-upload'.

Also, try 'alsamixer -c 0' on commandline to check all volume levels and input selections.
Comment 2 Audrius Meskauskas 2009-03-28 05:28:31 EDT
Where this alsa-info.sh can be found?

[audriusa@localhost ~]$ alsa-info.sh --no-upload
bash: alsa-info.sh: command not found
[audriusa@localhost ~]$ su
Password: 
[root@localhost audriusa]# alsa-info.sh --no-upload
bash: alsa-info.sh: command not found
[root@localhost audriusa]#
Comment 3 Audrius Meskauskas 2009-03-28 05:30:05 EDT
Created attachment 337097 [details]
 alsamixer -c 0
Comment 4 Audrius Meskauskas 2009-03-28 05:31:01 EDT
Created attachment 337098 [details]
 alsamixer -c 0 other s
Comment 5 Jaroslav Kysela 2009-04-02 12:33:08 EDT
The alsa-info.sh script can be obtained from http://www.alsa-project.org/alsa-info.sh . From your pictures, select Mic input in your mixer - press Space in alsamixer (second picture) or try to type this command on commandline:

amixer set Mic capture
Comment 6 Audrius Meskauskas 2009-04-10 02:29:42 EDT
I get the "Invalid command" message with the amixer:

[root@localhost audriusa]# amixer set Mic capture 
amixer: Invalid command!

However pressing "space" in the alsamixer worked: the computer captures the sound again and the Skype works.

I, however, would like to point that during the history of this bug I have used the "alsamixer" command first time since installation and I do not remember modifying anything in the sound settings before the sound have stopped working. Hence it still may be reasonable to check if some update does not override the alsamixer settings.

The issue is now fixed on my computer. Consider closing the bug.

Note You need to log in before you can comment on or make changes to this bug.