Bug 49148 - gcc Internal Error Segmentation Fault while compiling kernel
gcc Internal Error Segmentation Fault while compiling kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-15 16:22 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-15 16:22:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-15 16:22:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.6 i586; en-US; rv:0.9.1)
Gecko/20010622

Description of problem:
Using:gcc-objc-2.96-85
kgcc-1.1.2-40
gcc-g77-2.96-85
gcc-c++-2.96-85
gcc-2.96-85

Error:gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing
-fno-common -Wno-unused -pipe -mpreferred-stack-boundary=2 -march=k6    -c
-o ip_sockglue.o ip_sockglue.c
ip_sockglue.c: In function `ip_cmsg_recv_opts':
ip_sockglue.c:92: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [ip_sockglue.o] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.2/net/ipv4'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.2/net/ipv4'
make[1]: *** [_subdir_ipv4] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.2/net'
make: *** [_dir_net] Error 2

When I recompile the kernel again, without any modifications to what is
being compiled, it gets past the area where it crashed just fine and seg
faults at another point depending on how close to the end it is.




How reproducible:
Always

Steps to Reproduce:
1. cd /usr/src/linux
2. make menuconfig 
3. make dep ; make clean
4. make bzImage

	

Actual Results:  It seg faults at a certain area and then when make bzImage
is run again, it will compile where it left off but seg fault at a
different place. It never seg faults at the same place twice and each time
this is run, it will initally seg fault at a different place.

Expected Results:  It should have compiled the kernel

Additional info:

gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=k6    -c -o ip_sockglue.o ip_sockglue.c
ip_sockglue.c: In function `ip_cmsg_recv_opts':
ip_sockglue.c:92: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [ip_sockglue.o] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.2/net/ipv4'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.2/net/ipv4'
make[1]: *** [_subdir_ipv4] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.2/net'
make: *** [_dir_net] Error 2

I am using the updated version of gcc as supplied by Ximian's Red Carpet
application from the RedHat 7.1 subscription. I am running a AMD K6II 500
with 128 MB RAM and a ASUS P5A motherboard. 

This happens with all the kernels I have tried, including 2.4.2, 2.4.4, and
2.4.6

The kernel will eventually compile and work, but you keep having to make
bzImage over and over.
Comment 1 Jakub Jelinek 2001-07-16 14:55:56 EDT
I'd suggest you to run some memory checker because this is most probably
memory problem. It could be as well bad cache setting or some other hardware
or BIOS problem. It is definitely not a gcc bug. gcc bugs are reproducible
on the same input with the same options.

Note You need to log in before you can comment on or make changes to this bug.