Bug 49150 - Signal 11 during an upgrade from 6.2 to 7.1
Signal 11 during an upgrade from 6.2 to 7.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-15 17:47 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 23:54:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-15 17:47:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Right after the swap file has been turned on and as it is looking for 
packages to upgrade the installed crashes with a signal 11.  A look at the 
other terminals shows nothing unusual except for this line a few places 
above the last line: CD format is not recognized.  This crash has occured 
on two separate machines with 128 and 192 MB of ram each.

How reproducible:
Always

Steps to Reproduce:
1. Do upgrade
2. Signal 11 at the search for packages to upgrade
3.
	

Actual Results:  Signal 11

Expected Results:  Should upgrade

Additional info:
Comment 1 Need Real Name 2001-07-18 21:27:02 EDT
Jul 18 -- I have tried copyingthe install CD's to hard drive and creating 
a boot disk to eliminate the posibility of a cd-rom problem but this has not 
helped.  It is still crashing at the same place with a signal 11.
Comment 2 Brent Fox 2001-07-25 13:16:41 EDT
Did you verify the integrity of the ISO images with md5sum before you made the cd's?
Comment 3 Need Real Name 2001-07-25 17:09:02 EDT
The CD's were pruchased from CheapBytes.  I was able to back up data on one of 
my machiens and so  full install and all works fine.  The data on the CD is ok 
to do an install not an upgrade.
The second machine I have has too much data to be backed up with what little 
disk space I have but I will do what I have to I guess. I just wanted to see if 
there was something missing or a valid bug.
Comment 4 Michael Fulbright 2001-07-27 16:16:20 EDT
Please look on VC3 and VC4 when the error occurs and attach the last 8 lines on
each.
Comment 5 Need Real Name 2001-07-27 22:43:29 EDT
This is what I get for VC3

(starting at the top and going to the bottom of screen)
going to insmod radi0.o (path is NULL)
going to insmod radi1.o (path is NULL)
going to insmod xor.o (path is NULL)
going to insmod radi5.o (path is NULL)
going to insmod fat.o (path is NULL)
going to insmod msdos.o (path is NULL)
going to insmod vfat.o (path is NULL)
going to insmod ext3.o (path is NULL)
looking for USB mouse
no ide floppy devices found

This is for VC 4 (again top to bottom of screen)

ISO 9660 Extentsions RRIP_1991A
Unable to Identify CD-ROM format
RAID0 personality registered as nr2
RAID1 personality registered as nr3
RAID5 using function p5_MMX
RAID5 personality registered as nr4
adding swap 393208k Priority -1
Comment 6 Need Real Name 2001-07-30 21:29:11 EDT
Acquired a new set of cd's and tried an upgrade.  Got to teh same point and got 
teh same Signal 11 crash.  Same messages were displayed in the above VC3/4 
screens.
Comment 7 Brent Fox 2001-08-10 15:06:48 EDT
Can you try booting with 'linux ide=nodma'?  Does that help?
Comment 8 Need Real Name 2001-08-10 21:07:56 EDT
Tried the linux ide=nodma with both sets of discs I have and the signal 11 
creash still occurs
Comment 9 Brent Fox 2001-08-13 11:21:14 EDT
Jeff, does this sound like his RPM database could be corrupt?
Comment 10 Jeff Johnson 2001-08-13 11:29:26 EDT
Insufficient data to tell. Do a rpm --rebuilddb before upgrading
to eliminate the possibility.
Comment 11 Need Real Name 2001-08-13 21:51:43 EDT
Okay I did the rpm --rebuilddb and it crashed with a segmantation fault (core 
dumped).  Not sure where to go from here.  The upgrade still crashes.

Comment 12 Jeff Johnson 2001-08-13 23:54:31 EDT
Then that's an rpmdb problem.

A rebuild with rpm-4.0.3 should fix any/all problems. You'll
probably have to install manually using rpm2cpio.
Comment 13 Brent Fox 2001-08-16 11:14:01 EDT
Please reopen the bug if that doesn't fix the problem.

Note You need to log in before you can comment on or make changes to this bug.