Bug 491507 - SpamCop could not find your spam message in this email
SpamCop could not find your spam message in this email
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution-rspam (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Lucian Langa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 06:38 EDT by Heiko Adams
Modified: 2009-04-23 16:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 16:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spam report generated by evolution-rspam (657 bytes, application/octet-stream)
2009-03-22 06:38 EDT, Heiko Adams
no flags Details
Spamcop's bounce (3.91 KB, application/octet-stream)
2009-03-22 06:42 EDT, Heiko Adams
no flags Details
just another buggy spam reported generated by evolution-rspam (2.55 KB, application/octet-stream)
2009-03-22 18:20 EDT, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2009-03-22 06:38:57 EDT
Created attachment 336195 [details]
Spam report generated by evolution-rspam

Description of problem:
Since the last update spamcop could not find the spam message in the email generated by evolution-rspam.

Version-Release number of selected component (if applicable):
evolution.i386.2.24.5-1.fc10 
evolution-rspam.i386.0.0.6-4.fc10

How reproducible:
allways

Steps to Reproduce:
1. Select a spam message
2. Select "Report as Spam" from the context menu
3. Fetch mails some minutes after evolution has send the spam report
  
Actual results:
Spamcop bounces the mail

Expected results:
Spamcop should process the mail

Additional info:
Comment 1 Heiko Adams 2009-03-22 06:42:33 EDT
Created attachment 336196 [details]
Spamcop's bounce
Comment 2 Lucian Langa 2009-03-22 08:36:57 EDT
Thanks for your report, is it possible you could also attach the mail generated by rspam to spamcop (it should be on your sent folder).
Thank you.
Comment 3 Heiko Adams 2009-03-22 08:47:58 EDT
I've already done this. It should be the first attachment.
Comment 4 Heiko Adams 2009-03-22 18:20:38 EDT
Created attachment 336226 [details]
just another buggy spam reported generated by evolution-rspam
Comment 5 Lucian Langa 2009-03-23 02:22:22 EDT
Looking at this last message, report seems well formatted do you also get the same spamcop error (bounce) for this one ?
Comment 6 Heiko Adams 2009-03-23 07:51:51 EDT
Yes, for every spam report generated by evolution-rspam I get the same spamcop error. Manually forwarding the spam messages works well.
Comment 7 Lucian Langa 2009-03-26 11:20:10 EDT
(In reply to comment #6)
> Yes, for every spam report generated by evolution-rspam I get the same spamcop
> error. 
I was asking because last report you send (id=336226) does contain the message you reported and headers are properly set and I doubt spamcop bounce error message could be the same.
Spamcop message: "SpamCop encountered errors while saving spam for processing:
SpamCop could not find your spam message in this email:"

>Manually forwarding the spam messages works well.  
Plain forwarding a 'report spam' generated by evolution-rspam should not work. How do you do it ? Attachment ? Please explain this.
Comment 8 Heiko Adams 2009-03-26 15:48:09 EDT
As I wrote before: Every spam report generated by evolution-rspam is bounced with 
> SpamCop encountered errors while saving spam for processing:
> SpamCop could not find your spam message in this email:"
as error message.

If I forward the spam messages manualy as attachment spamcop doesn't bounce that mail. So for me it looks like the evolution-rspam doesn't set the attachment header correctly.
Comment 9 Lucian Langa 2009-04-13 16:23:47 EDT
Is it possible you could try the new release version:
https://koji.fedoraproject.org/koji/buildinfo?buildID=97738
it is possible that this problemcould be fixed already.
Comment 10 Heiko Adams 2009-04-23 16:42:42 EDT
Seems to work with latest update. I've submitted spam by using rspam and got *no* bounce from spamcop.

Note You need to log in before you can comment on or make changes to this bug.