Bug 491514 - QT translations fail to build with "lrelease error: duplicate messages found in file.ts"
QT translations fail to build with "lrelease error: duplicate messages found ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
http://bugs.avidemux.org/index.php?do...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 10:04 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2009-03-25 17:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 09:03:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build log from a failed build in mock/rawhide (2.33 MB, text/plain)
2009-03-23 18:50 EDT, Dominik 'Rathann' Mierzejewski
no flags Details

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2009-03-22 10:04:07 EDT
Description of problem:
Since qt-4.5.0 duplicate messages in .ts files produce fatal errors instead of warnings. That causes many applications to fail to build, for example avidemux-2.4.3 and 2.4.4.

Version-Release number of selected component (if applicable):
qt-4.5.0-3.fc11

How reproducible:
Always.

Additional info:
This could be related to this issue http://www.qtsoftware.com/developer/task-tracker/index_html?method=entry&id=247738
Comment 1 Rex Dieter 2009-03-22 11:28:53 EDT
Indeed, looks like that issue alright.
Comment 2 Ngo Than 2009-03-23 08:02:34 EDT
i can rebuild avidemux-2.4.4 with qt-4.5.0 without this issue.
could you please add the build logfile that includes the errors? I also need a testcase to reproduce this issue. Thanks
Comment 3 Dominik 'Rathann' Mierzejewski 2009-03-23 18:50:43 EDT
Created attachment 336408 [details]
build log from a failed build in mock/rawhide

Here's the log. I've uploaded the src.rpm to http://rpm.greysector.net/rpmfusion/avidemux-2.4.4-1.fc11.src.rpm
Comment 4 Ngo Than 2009-03-24 09:03:36 EDT
it's fixed in qt-4_5_0-9_fc11.
Comment 5 Dominik 'Rathann' Mierzejewski 2009-03-25 17:03:16 EDT
Confirmed, thanks.

Note You need to log in before you can comment on or make changes to this bug.