Bug 491526 - Maybe dumb question, but how to select swap partition in Anaconda?
Maybe dumb question, but how to select swap partition in Anaconda?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
anaconda_trace_hash:b3a67c16a1c1dd815...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 12:43 EDT by Miroslav Šustek
Modified: 2009-03-23 20:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 18:40:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (111.38 KB, text/plain)
2009-03-22 12:43 EDT, Miroslav Šustek
no flags Details

  None (edit)
Description Miroslav Šustek 2009-03-22 12:43:25 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.12 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 282, in setup
    raise FormatSetupError("invalid device specification")
  File "/usr/lib/anaconda/storage/formats/swap.py", line 117, in setup
    DeviceFormat.setup(self, *args, **kwargs)
  File "/usr/lib/anaconda/storage/__init__.py", line 1356, in turnOnSwap
    device.format.setup()
  File "/usr/lib/anaconda/packages.py", line 193, in turnOnFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda.intf)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
FormatSetupError: invalid device specification
Comment 1 Miroslav Šustek 2009-03-22 12:43:33 EDT
Created attachment 336203 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-23 10:15:34 EDT
anaconda-11.4.0.12 is a very old release at this point.  Perhaps you are using an older local mirror, or a mirror that has not updated in several weeks.  Can you please try with the latest rawhide and see if this problem is reproducable there?  Thanks.
Comment 3 David Cantrell 2009-03-23 18:40:49 EDT
Unable to reproduce on rawhide.  I did an autopart install and a custom partitioning install and swap was created.
Comment 4 Miroslav Šustek 2009-03-23 20:07:13 EDT
I did an custom partition install.

I have tried official mirror (fedora.redhat.com), too but with same results.
Even though I followed the same procedure, it gave me the same results:
this one and #489520: https://bugzilla.redhat.com/attachment.cgi?id=336210 .

Maybe it was because of specific partition table.
Then I solved my situation by deleting swap partitions. Anaconda asked whether to continue without swap (clicked YES) and everything gone well then. And after installation I enabled the swap manually.

It is not best solution, but it works for me.

(IMHO Anaconda (v11) is great and looks very user friendly, but has a few hidden bugs. Eg. unhandled exceptions almost every time you close a dialog window by escape key. And unhandled exceptions make whole installation worthless.)
Comment 5 Miroslav Šustek 2009-03-23 20:22:45 EDT
(In reply to comment #4)
> Even though I followed the same procedure, it gave me the same results:
> this one and #489520: https://bugzilla.redhat.com/attachment.cgi?id=336210 .
I mean that with the same procedure it "randomly" gave me two different errors.
I also tried to format to ext3, ext2, tried to format swap in Anaconda and always got one of these two errors.
I'd like to help you, but I really don't know (without crunching through the source code) why "it does what it does and isn't supposed to do". :)

Note You need to log in before you can comment on or make changes to this bug.