Bug 491536 - cssh is broken
cssh is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Tk (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 15:43 EDT by Need Real Name
Modified: 2009-07-02 05:05 EDT (History)
13 users (show)

See Also:
Fixed In Version: 804.028-9.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 01:46:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-03-22 15:43:47 EDT
A big of a nightmare, cssh is broken in rawhide:

$ cssh root@BLAH
no event type or button # or keysym at /usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi/Tk/Widget.pm line 1105.
 at /usr/bin/cssh line 1434
Comment 1 manuel wolfshant 2009-04-01 07:49:37 EDT
I confirm that the same bug appears in Centos 5, even when using clusterssh-3.25 (rebuilt from rawhide spec + latest upstream sources).

I am not sure if this is related or not, but in F-10 I get:

([wolfy@wolfy ~]$  cssh zoli
Cannot open pipe for reading when talking to zoli: No child processes
Use of uninitialized value $win in concatenation (.) or string at /usr/bin/cssh line 792.
Protocol error: bad 3 (Window); Sequence Number 8
 Opcode (10, 0) = UnmapWindow
 Bad resource 0 (0x0)
 at /usr/bin/cssh line 799
Comment 2 Need Real Name 2009-05-01 06:20:37 EDT
I am still unable to admin multiple servers using cssh in Fedora 11.
Comment 3 Aaron Toponce 2009-05-05 18:01:36 EDT
I can also confirm the bug on 32-bit:

$ cat /etc/redhat-release
Fedora release 10.93 (Leonidas)
$ uname -r
2.6.29.1-111.fc11.i586
$ rpm -q clusterssh
clusterssh-3.22-2.fc11.noarch
$ rpm -q perl-Tk
perl-Tk-801.028-7.fc11.i586
$ cssh foo
no event type or button # or keysym at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Tk/Widget.pm line 1105.
 at /usr/bin/cssh line 1434
Comment 4 Ales Zelinka 2009-05-11 08:21:25 EDT
This seems to be a bug in perl-tk package - the line mentioned in the error message is some windows-specific code which (afaik) should not be executed on linux. (I've downloaded few other perl-tk utilities from web and lots of them crashes with the same error but work when the line is commented out)

Adding perl-tk's maintainer to CC-list.

Andreas, could you please take a look at this bug and reassign it to your component, if it's perl-tk issue?
Comment 5 Bug Zapper 2009-06-09 08:29:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Geoff Sternecker 2009-06-10 15:02:53 EDT
I was able to resolve the issue by patching the file 
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi/Tk/Widget.pm with a patch from http://bugs.gentoo.org/attachment.cgi?id=178622&action=view.

$ cat /etc/redhat-release 
Fedora release 11 (Leonidas)
$ uname -r
2.6.29.4-167.fc11.x86_64
$ rpm -q clusterssh
clusterssh-3.22-2.fc11.noarch
$ rpm -q perl-Tk
perl-Tk-804.028-7.fc11.x86_64


diff of Widget.pm, After patching with the perl-tk-804.028-Widget-mousewheel-bind.patch from Bryan D. Stine <battousai@gentoo.org> 

$ diff Widget.pm Widget.pm.orig 
1103a1104,1106
>  $mw->Tk::bind($class, '<MouseWheel>',
> 	       [ sub { $_[0]->yview('scroll',-($_[1]/120)*3,'units') }, Tk::Ev("D")]);
> 
1119,1124d1121
<  elsif ($Tk::platform eq 'MSWin32')
<   {
<     $mw->Tk::bind($class, '<MouseWheel>',
< 	       [ sub { $_[0]->yview('scroll',-($_[1]/120)*3,'units') }, Tk::Ev("D")]);
< 
<   }

clusterssh is working for me..
Comment 7 manuel wolfshant 2009-06-11 00:40:15 EDT
Unsurprisingly, even with the above patch I still get:
# cssh root@biblioteca
Cannot open pipe for reading when talking to biblioteca: No child processes
Use of uninitialized value $win in concatenation (.) or string at /usr/bin/cssh line 792.
Protocol error: bad 3 (Window); Sequence Number 8
 Opcode (10, 0) = UnmapWindow
 Bad resource 0 (0x0)
 at /usr/bin/cssh line 799

[wolfy@wolfy tmp]$ uname -r
2.6.27.21-170.2.56.fc10.x86_64
[wolfy@wolfy tmp]$ rpm -q clusterssh
clusterssh-3.25-1.fc10.noarch
[wolfy@wolfy tmp]$ rpm -q perl-Tk
perl-Tk-804.028-5.fc9.x86_64
Comment 8 Geoff Sternecker 2009-06-11 08:37:49 EDT
Sorry Manuel, the patch above was intended just for the error:

no event type or button # or keysym at
/usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Tk/Widget.pm line
1105.
 at /usr/bin/cssh line 1434
Comment 9 Patrick Laughton 2009-06-12 14:55:44 EDT
This seems to be the same problem as described in bug #489228 comment #8.  I've attached a patch there that seems to remedy both.  I think we can effectively call one a duplicate of the other.  Comments?
Comment 10 manuel wolfshant 2009-06-12 16:32:19 EDT
Unfortunately that patch does not fix the error that I see :( I get the exact same error, even after rebuilding for Fedora 10 the current perl-Tk + perl-Tk-fix.patch from  bug #489228 . The error is identical to the one pasted in comment #7 .
Comment 11 Patrick Laughton 2009-06-12 23:51:31 EDT
Okay, going back to comment #7 and attempting to duplicate that error...

# uname -r;rpm -q clusterssh perl-Tk
2.6.27.24-170.2.68.fc10.x86_64
clusterssh-3.22-1.fc9.noarch
perl-Tk-804.028-5.fc9.x86_64

Doing a straightforward `cssh root@host` works.  I think there's something else at play here.  Crud.
Comment 12 Christoph Maser 2009-06-16 13:45:18 EDT
same problem here:

uname -r;rpm -q clusterssh perl-Tk
2.6.29.4-167.fc11.x86_64
clusterssh-3.22-2.fc11.noarch
perl-Tk-804.028-7.fc11.x86_64

cssh root@host
no event type or button # or keysym at /usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi/Tk/Widget.pm line 1105.
 at /usr/bin/cssh line 1434
Comment 13 Fedora Update System 2009-06-22 13:02:29 EDT
perl-Tk-804.028-8.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/perl-Tk-804.028-8.fc10
Comment 14 Fedora Update System 2009-06-22 13:03:19 EDT
perl-Tk-804.028-8.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/perl-Tk-804.028-8.fc11
Comment 15 Need Real Name 2009-06-22 13:14:25 EDT
WFM THANKS!
Comment 16 Fedora Update System 2009-06-26 22:44:09 EDT
perl-Tk-804.028-9.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Tk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6974
Comment 17 Fedora Update System 2009-06-26 22:57:56 EDT
perl-Tk-804.028-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Tk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7022
Comment 18 Mohammed Arafa 2009-06-28 01:49:32 EDT
that fixed it! 

thanks
Comment 19 Erinn Looney-Triggs 2009-06-29 15:49:09 EDT
Works for me as well. No ill effects thus far.
Comment 20 Fedora Update System 2009-07-02 01:45:54 EDT
perl-Tk-804.028-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2009-07-02 01:50:57 EDT
perl-Tk-804.028-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.