Bug 491553 - system-config-services does not show all background services
system-config-services does not show all background services
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-services (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Nils Philippsen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 18:58 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-19 12:01:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2009-03-22 18:58:55 EDT
Description of problem:
system-config-services does not list all background services that are available on the system. 

Version-Release number of selected component (if applicable):
system-config-services-0.9.4-1.el5

How reproducible:
always

Steps to Reproduce:
1. Install base RHEL5, Install ipw3945d from Supp
2. system-config-services does not show ipw3945d as a background service
3.
  
Actual results:
system-config-services does not show ipw3945d as a background service

Expected results:
system-config-services should list ipw3945d as a background service

Additional info:
Comment 1 Nils Philippsen 2009-03-23 09:05:31 EDT
I can see the ipw3945d service as a background service on RHEL 5.3 just fine:

[root@dhcp-5-178 ~]# cat /etc/*release
Red Hat Enterprise Linux Server release 5.3 (Tikanga)
[root@dhcp-5-178 ~]# rpm -q system-config-services ipw3945d
system-config-services-0.9.4-1.el5
ipw3945d-1.7.22-2.el5
[root@dhcp-5-178 ~]# 

Do you get any error messages? What do "service ipw3945d status" and "chkconfig --list ipw3945d" give?
Comment 2 Subhendu Ghosh 2009-04-26 22:54:59 EDT
If you have a system without ipw3945d installed, s-c-s does not show ipw3945d as expected. If you then install ipw3945d and without doing anything with chkconfig, run s-c-s, you don't see ipw3945d in the background services list.

s-c-s picks up ipw3945d only after you have run "chkconfig ip3945d on"
Shouldn't it pick it up when the install is performed?


same versions.
No error msgs based on the above commands.
Comment 4 Nils Philippsen 2009-05-26 07:03:22 EDT
(In reply to comment #2)
> If you have a system without ipw3945d installed, s-c-s does not show ipw3945d
> as expected. If you then install ipw3945d and without doing anything with
> chkconfig, run s-c-s, you don't see ipw3945d in the background services list.
> 
> s-c-s picks up ipw3945d only after you have run "chkconfig ip3945d on"
> Shouldn't it pick it up when the install is performed?

It should.

> same versions.
> No error msgs based on the above commands.  

Didn't express myself too clearly: I was interested in error messages if you run s-c-services from the command line, and the output of "service ipw3945d status" and "chkconfig --list ipw3945d" regardless of if they give an error or not. Would you please provide that info? Thanks.
Comment 5 Subhendu Ghosh 2009-06-09 23:03:51 EDT
$ service ipw3945d status
ipw3945d (pid 2718) is running...

$ chkconfig --list ipw3945d
ipw3945d        0:off   1:off   2:on    3:on    4:on    5:on    6:off

No errors reported on the terminal when starting s-c-services from cli before ipw3945d was visible or after it was visible.
Comment 6 Phil Knirsch 2009-09-14 11:21:58 EDT
Might the problem lie with the ipw3945d package and the post install script i has?

Thanks & regards, Phil
Comment 8 Nils Philippsen 2009-11-17 11:45:31 EST
I've found that the description line is mis-formatted (for chkconfig headers, description must use backslashes for line continuation). I don't know right now if that contributes to the problem, though.
Comment 10 Nils Philippsen 2009-11-19 08:22:26 EST
Hm, try as I might, I can't reproduce the problem here: I took a RHEL5 machine where ipw3945d wasn't installed (but s-c-services was), installed it, started s-c-services and found ipw3945d in the list of services (all with the versions mentioned above).

Do the packages involved verify correctly ("rpm -V ipw3945d system-config-services")? Does running "package-cleanup --dupes --problems" (from the yum-utils package) yield anything?

Note You need to log in before you can comment on or make changes to this bug.