Bug 491633 - Fedora11 Alpha kvm guest install - virt-manager fails to load the iso image
Fedora11 Alpha kvm guest install - virt-manager fails to load the iso image
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
x86_64 All
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 08:40 EDT by IBM Bug Proxy
Modified: 2009-05-07 03:15 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-virtinst-0.400.3-7.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 03:15:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing error message (179.29 KB, image/png)
2009-03-23 08:40 EDT, IBM Bug Proxy
no flags Details
audit.log (433.69 KB, text/plain)
2009-03-23 08:41 EDT, IBM Bug Proxy
no flags Details
/var/log/libvirt/qemu/f11Guest.log (544 bytes, text/plain)
2009-03-23 08:41 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2009-03-23 08:40:50 EDT
=Comment: #0=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> - 

virt-manager fails to load the iso image during the kvm quest installation of F11Alpha. 
Following is the error message I get..

========================

Unable to complete install '<class 'libvirt.libvirtError'> internal error QEMU quit during console
startup
qemu: could not open disk image /root/Fedora-11-Alpha-x86_64-DVD.iso

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 717, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 926, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 966, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 915, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error QEMU quit during console startup
qemu: could not open disk image /root/Fedora-11-Alpha-x86_64-DVD.iso

=========================

However, "qemu-kvm" command is able to recognise the iso properly and proceed with installation.
Attachment: Screenshot showing error message
Attachment: /var/log/libvirt/qemu/f11Guest.log

=Comment: #3=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> - 
> Is selinux enabled on this machine? 
Machine was enable with selinux. 
Disabled selinux and tried, installation of guest got started without seeing the reported problem.

> Also can you please move the ISO to /var/lib/libvirt/images/ and try again? 
With selinux enabled, moving the ISO to /var/lib/libvirt/images/ did not help.

=Comment: #4=================================================
Anoop V. Chakkalakkal <anoop.vijayan@in.ibm.com> - 
Attachment: audit.log
Comment 1 IBM Bug Proxy 2009-03-23 08:40:59 EDT
Created attachment 336280 [details]
Screenshot showing error message
Comment 2 IBM Bug Proxy 2009-03-23 08:41:08 EDT
Created attachment 336281 [details]
audit.log
Comment 3 IBM Bug Proxy 2009-03-23 08:41:15 EDT
Created attachment 336282 [details]
/var/log/libvirt/qemu/f11Guest.log
Comment 4 Daniel Walsh 2009-03-23 13:38:46 EDT
If you upgrade to the latest libvirt most of these problems will dissapear. 

If you install a virtual machine you need to label the iso image virt_image_t, so 

chcon -t virt_image_t /root/*.iso

The current libvirt will not run pulseaudio so other problems should be fixed.

Please update selinux-policy-targeted and libvirt and see if it works for you.
Comment 5 IBM Bug Proxy 2009-04-03 07:11:12 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-04-03 07:05 EDT-------
(In reply to comment #9)
> If you upgrade to the latest libvirt most of these problems will dissapear.
>
> If you install a virtual machine you need to label the iso image virt_image_t,
> so
>
> chcon -t virt_image_t /root/*.iso
>
> The current libvirt will not run pulseaudio so other problems should be fixed.
>
> Please update selinux-policy-targeted and libvirt and see if it works for you.
>

Redhat, I check this in f11beta and I still see the error without labeling iso and selinux enabled..

libvirt version in f11beta is
# libvirtd --version
libvirtd (libvirt) 0.6.1

libvirt-0.6.1-5.fc11.x86_64

Does this libvirt has the fix for issue reported?
Comment 6 IBM Bug Proxy 2009-04-14 05:31:46 EDT
------- Comment From anoop.vijayan@in.ibm.com 2009-04-14 05:25 EDT-------
> Redhat, I check this in f11beta and I still see the error without labeling iso
> and selinux enabled..
>
> libvirt version in f11beta is
> # libvirtd --version
> libvirtd (libvirt) 0.6.1
>
> libvirt-0.6.1-5.fc11.x86_64
>
> Does this libvirt has the fix for issue reported?
>

Looks like you have to label installation images as of now. There is a F10 bugzilla [https://bugzilla.redhat.com/show_bug.cgi?id=477187] already dealing with this issue of whether the installation image needs to have a separate context from the actual guest disk image. This looks to be the F11 counterpart..
Comment 7 IBM Bug Proxy 2009-04-15 00:46:02 EDT
Reopening based on the previous comment...
Comment 8 Daniel Walsh 2009-05-01 14:01:46 EDT
I think this will be fixed by the latest libvirt patch for SELinux.
Comment 9 Mark McLoughlin 2009-05-04 11:37:10 EDT
Please retry with python-virtinst-0.400.3-4.fc11 or later and let us know if the problem still persists. Thanks
Comment 10 IBM Bug Proxy 2009-05-07 03:11:18 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-05-07 03:07 EDT-------
(In reply to comment #17)
> Please retry with python-virtinst-0.400.3-4.fc11 or later and let us know if
> the problem still persists. Thanks
>

I did not see this problem in python-virtinst-0.400.3-7.fc11.

Thanks
Pavan
Comment 11 Mark McLoughlin 2009-05-07 03:15:35 EDT
Thanks

Note You need to log in before you can comment on or make changes to this bug.