Bug 491667 - Uninstall of proxy fail if run after canceled installation
Uninstall of proxy fail if run after canceled installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
https://riverraid.rhndev.redhat.com/n...
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-03-23 10:55 EDT by wes hayutin
Modified: 2009-09-10 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:38:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proxy uninstall error (9.18 KB, text/plain)
2009-05-07 17:27 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-03-23 10:55:56 EDT
Description of problem:

Proxy uninstall action fails after deactivation.

This action should pass if.
1. it successfully uninstalls any package related to proxy
2. runs, and does not find proxy packages.

recreate.
1. setup proxy to install in webui
2. cancel the install events
3. go to proxy tab, deactivate and remove packages


script fails
This action will be executed after 03/23/09 10:51:17 AM EDT.

This action's status is: Failed.
This action has not yet been picked up.

Run as: root:root
Timeout: 600 seconds

#!/bin/sh
rpm -e `for package in bdb_perl ConfigPusher-general eventReceivers FcntlLock jabberd libapreq2 MessageQueue mm mod_perl NOCpulsePlugins np-config NPalert NPusers nslogs oracle-devel oracle_perl perl-Apache-Admin-Config perl-Apache-DBI perl-BerkeleyDB perl-BSD-Resource perl-Class-MethodMaker perl-Class-Singleton perl-Config-IniFiles perl-Crypt-DES perl-Crypt-GeneratePassword perl-Crypt-SSLeay perl-DateTime perl-DateTime-Locale perl-DateTime-TimeZone perl-DBD-Oracle perl-Devel-Symdump perl-Error perl-FreezeThaw perl-HTML-TableExtract perl-IO-Capture perl-IO-Socket-SSL perl-IO-stringy perl-libapreq2 perl-Mail-Alias perl-MailTools perl-MIME-tools perl-Net-SNMP perl-Network-IPv4Addr perl-Net_SSLeay perl-NOCpulse-CLAC perl-NOCpulse-Debug perl-NOCpulse-Gritch perl-NOCpulse-Object perl-NOCpulse-OracleDB perl-NOCpulse-PersistentConnection perl-NOCpulse-Probe perl-NOCpulse-ProcessPool perl-NOCpulse-Scheduler perl-NOCpulse-SetID perl-NOCpulse-Utils perl-Params-Validate perl-TimeDate perl-XML-Generator ProgAGoGo python-sgmlop rhn-base-minimal rhn-ssl-cert-check rhns rhns-auth-daemon rhns-certs-tools rhns-proxy-broker rhns-proxy-common rhns-proxy-docs rhns-proxy-management rhns-proxy-monitoring rhns-proxy-package-manager rhns-proxy-redirect rhns-proxy-tools SatConfig-ApacheDepot SatConfig-bootstrap SatConfig-bootstrap-server SatConfig-cluster SatConfig-dbsynch SatConfig-general SatConfig-generator SatConfig-installer SatConfig-spread scdb scdb_accessor_perl SNMPAlerts SputLite-client SputLite-server ssl_bridge status_log_acceptor Time-System tsdb tsdb_accessor_perl httpd mod_python mod_ssl mod_ssl httpd-suexec; do
rpm -q $package >/dev/null && echo $package; done`


Start Date: (unknown)
End Date: (unknown)
Return Code: 0
Raw Output: view/download raw script output
Filtered Output:
Comment 1 Miroslav Suchý 2009-03-26 10:22:51 EDT
Commited as 61f9238b239208ba47fd0336cade55df844addef
Fixed in spacewalk-web-0.5.21-1
Comment 2 wes hayutin 2009-03-30 15:30:45 EDT
verified

This action's status is: Completed.
The client picked up this action on 03/30/09 3:29:33 PM EDT.
The client completed this action on 03/30/09 3:29:43 PM EDT.
Client execution returned "Script executed" (code 0)


Run as: root:root
Timeout: 600 seconds

#!/bin/sh
PACKAGES=`for package in bdb_perl ConfigPusher-general eventReceivers FcntlLock jabberd libapreq2 MessageQueue mm mod_perl NOCpulsePlugins np-config NPalert NPusers nslogs oracle-devel oracle_perl perl-Apache-Admin-Config perl-Apache-DBI perl-BerkeleyDB perl-BSD-Resource perl-Class-MethodMaker perl-Class-Singleton perl-Config-IniFiles perl-Crypt-DES perl-Crypt-GeneratePassword perl-Crypt-SSLeay perl-DateTime perl-DateTime-Locale perl-DateTime-TimeZone perl-DBD-Oracle perl-Devel-Symdump perl-Error perl-FreezeThaw perl-HTML-TableExtract perl-IO-Capture perl-IO-Socket-SSL perl-IO-stringy perl-libapreq2 perl-Mail-Alias perl-MailTools perl-MIME-tools perl-Net-SNMP perl-Network-IPv4Addr perl-Net_SSLeay perl-NOCpulse-CLAC perl-NOCpulse-Debug perl-NOCpulse-Gritch perl-NOCpulse-Object perl-NOCpulse-OracleDB perl-NOCpulse-PersistentConnection perl-NOCpulse-Probe perl-NOCpulse-ProcessPool perl-NOCpulse-Scheduler perl-NOCpulse-SetID perl-NOCpulse-Utils perl-Params-Validate perl-TimeDate perl-XML-Generator ProgAGoGo python-sgmlop rhn-base-minimal rhn-ssl-cert-check rhns rhns-auth-daemon rhns-certs-tools rhns-proxy-broker rhns-proxy-common rhns-proxy-docs rhns-proxy-management rhns-proxy-monitoring rhns-proxy-package-manager rhns-proxy-redirect rhns-proxy-tools SatConfig-ApacheDepot SatConfig-bootstrap SatConfig-bootstrap-server SatConfig-cluster SatConfig-dbsynch SatConfig-general SatConfig-generator SatConfig-installer SatConfig-spread scdb scdb_accessor_perl SNMPAlerts SputLite-client SputLite-server ssl_bridge status_log_acceptor Time-System tsdb tsdb_accessor_perl httpd mod_python mod_ssl httpd-suexec; do
rpm -q $package >/dev/null && echo $package; done`
if [ -n "$PACKAGES" ]; then
rpm -e $PACKAGES
fi


Start Date: 2009-03-30 15:29:33
End Date: 2009-03-30 15:29:41
Return Code: 0
Raw Output: view/download raw script output
Filtered Output:

warning: /etc/httpd/conf.d/ssl.conf saved as /etc/httpd/conf.d/ssl.conf.rpmsave
warning: /etc/rhn/rhn.conf saved as /etc/rhn/rhn.conf.rpmsave
warning: /etc/httpd/conf.d/rhn_proxy.conf saved as /etc/httpd/conf.d/rhn_proxy.conf.rpmsave
warning: /etc/jabberd/sm.xml saved as /etc/jabberd/sm.xml.rpmsave
warning: /etc/jabberd/c2s.xml saved as /etc/jabberd/c2s.xml.rpmsave
Comment 3 wes hayutin 2009-05-07 17:26:14 EDT
recreate:
1. install proxy via webui on clean rhel build
2. remove system profile
3. reregister the box run webui proxy installer


fails w/ error in txt
Comment 4 wes hayutin 2009-05-07 17:27:13 EDT
Created attachment 342940 [details]
proxy uninstall error
Comment 5 wes hayutin 2009-05-07 17:27:55 EDT
In prior Satellite releases the following was successful.
1. install proxy via webui on clean rhel build
2. remove system profile
3. reregister the box run webui proxy installer
Comment 6 wes hayutin 2009-05-07 17:29:01 EDT
Brandon, can you please comment on this bug.
I'm not 100% this is a priority for development.  Your thoughts on the issue?
Comment 7 wes hayutin 2009-05-07 17:57:12 EDT
FYI..
this actually works on a fresh rhel 5 proxy 5.3 webui install, and then reinstalling on a fresh rhel 5 proxy webui install.

Looking at the uninstall script it just seems to be very brittle and prone to dependency issues.  See comment #4
Comment 8 Brandon Perkins 2009-05-11 22:38:18 EDT
Trying to follow, but it looks like this should be back ON_QA as it has been verified?
Comment 9 wes hayutin 2009-05-12 09:52:53 EDT
verified
Comment 10 Milan Zazrivec 2009-08-11 10:39:53 EDT
Testing in stage:
* Canceled webui proxy installation - OK
* Deactivation of proxy installed from webui - OK
* Deactivation of proxy installed via cli - OK

RELEASE_PENDING
Comment 11 Brandon Perkins 2009-09-10 10:38:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.