This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 491668 - Raw output of action, view download raw script output, not working
Raw output of action, view download raw script output, not working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
wes hayutin
https://riverraid.rhndev.redhat.com/n...
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-23 11:00 EDT by wes hayutin
Modified: 2009-09-10 16:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-23 11:00:01 EDT
Description of problem:
Satellite-5.3.0-RHEL5-re20090320.0-i386-embedded-oracle.iso

schedule an action that has output, like a script.
go into the event after execution and click

"view/download raw script output"

results: 
dont get results:

<?xml version="1.0" encoding="utf8"?>
<pxt-passthrough><pxt-use class="Sniglets::ServerActions" /><rhn-raw-script-output /></pxt-passthrough>


actual results:
show results of command



Run as: root:root
Timeout: 600 seconds

#!/bin/sh
ls


Start Date: 2009-03-23 10:59:45
End Date: 2009-03-23 10:59:45
Return Code: 0
Raw Output: view/download raw script output
Filtered Output:

bin
boot
dev
etc
hde_pdc.dat
hde_pdc.offset
home
initrd
lib
lost+found
media
misc
mnt
opt
proc
root
sbin
selinux
srv
sys
tmp
usr
var
Comment 1 Shannon Hughes 2009-03-25 13:59:10 EDT
this was working for me....putting back to onqa per weshay request.
Comment 2 wes hayutin 2009-03-26 16:27:43 EDT
this appears to be working on grandprix 3/23 build
This action will be executed after 03/26/09 4:25:00 PM EDT.

This action's status is: Completed.
The client picked up this action on 03/26/09 4:26:04 PM EDT.
The client completed this action on 03/26/09 4:26:05 PM EDT.
Client execution returned "Script executed" (code 0)


Run as: root:root
Timeout: 600 seconds

#!/bin/sh
ls


Start Date: 2009-03-26 16:26:04
End Date: 2009-03-26 16:26:04
Return Code: 0
Raw Output: view/download raw script output
Filtered Output:

bin
boot
dev
etc
hde_pdc.dat
hde_pdc.offset
home
initrd
lib
lost+found
media
misc
mnt
opt
proc
root
sbin
selinux
srv
sys
tmp
usr
var



link does too... passing
Comment 3 wes hayutin 2009-03-30 12:21:47 EDT
recreated while installing proxy via webui..
https://riverraid.rhndev.redhat.com/network/systems/details/history/raw_script_output.txt?hid=8&sid=1000010000

<?xml version="1.0" encoding="utf8"?>
<pxt-passthrough><pxt-use class="Sniglets::ServerActions" /><rhn-raw-script-output /></pxt-passthrough>


recreate..
1.register system
2. install httpd
3. attempt to install proxy via webui..
4. get script failure...

look at the script.
Comment 4 wes hayutin 2009-03-30 12:25:25 EDT
one more..
to get the installer to fail..
1. install httpd
2. install spacewalk-proxy-installer
Comment 5 Brad Buckingham 2009-04-06 16:59:15 EDT
master commit: 4c405b8d7c9b7e59109baee7a99f2eeca9e6a906
vader commit: 55fba08455e34e03855a505b41d9c60286351bc9

I was able to reproduce the original issue as described in the initial
description using the latest Satellite code.  After investigation, this
issue appears to be related to the move away from using the 
satellite-httpd to using the standard httpd configuration with satellite's
specific config overlayed on top of it.

The current httpd.conf file that is deployed as part of Apache has the following
configuration:

<Directory "/var/www/html">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

The value of "None" for AllowOverride basically disables the support for
the .htaccess files within the application directories that reside under
/var/www/html.  This is a problem for Spacewalk because we need the
.htaccess files to be processed and supported; otherwise, several of
the perl pages are affected.

Unfortunately, the above Directory block is processed after the
zz-spacewalk-www.conf and zz-spacewalk-server.conf files are read in.
As a result, this block overrides the current zz configurations.

In order to avoid making modifications to the standard httpd.conf,
this commit will add a new entry to the zz conf that will basically
'fake' out Apache by creating a separate document with a path
of /var/www/html/*.
Comment 6 wes hayutin 2009-04-23 12:55:58 EDT
verified
Comment 7 Miroslav Suchý 2009-08-25 09:03:35 EDT
verified in stage on xen5
Comment 8 Brandon Perkins 2009-09-10 16:34:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.