Bug 491706 - webcam microphone not recognized: module-alsa-card errors...
webcam microphone not recognized: module-alsa-card errors...
Status: CLOSED DUPLICATE of bug 489048
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 13:27 EDT by Tom London
Modified: 2009-03-24 15:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 15:19:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-03-23 13:27:17 EDT
Description of problem:
[Please "re-tag" this issue if I erroneously filed it against pulseaudio.]

Plugging in a Logitech webcam, I get the message spew below, with:

Mar 23 09:49:31 tlondon pulseaudio[3214]: module-alsa-card.c: Card '1' doesn't exist: Permission denied
Mar 23 09:49:31 tlondon pulseaudio[3214]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id=1 name=usb_device_46d_991_268AC312_if2_sound_card_0 card_name=alsa_card.usb_device_46d_991_268AC312_if2_sound_card_0 tsched=1"): initialization failed.

Nevertheless, the camera still works (I can run "cheese" or "ucview").

But, pulseaudio appears not to be aware of the microphone: the sound preferences applet doesn't list it under the "input" tab.

Complete list of messages in /var/log/messages:

Mar 23 09:49:30 tlondon kernel: usb 1-1: new high speed USB device using ehci_hcd and address 8
Mar 23 09:49:30 tlondon kernel: usb 1-1: New USB device found, idVendor=046d, idProduct=0991
Mar 23 09:49:30 tlondon kernel: usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=2
Mar 23 09:49:30 tlondon kernel: usb 1-1: SerialNumber: 268AC312
Mar 23 09:49:30 tlondon kernel: usb 1-1: configuration #1 chosen from 1 choice
Mar 23 09:49:30 tlondon pulseaudio[3214]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuchProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_46d_991_268AC312
Mar 23 09:49:30 tlondon pulseaudio[3214]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuchProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_46d_991_268AC312_if1
Mar 23 09:49:30 tlondon pulseaudio[3214]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuchProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_46d_991_268AC312_if3
Mar 23 09:49:30 tlondon kernel: Linux video capture interface: v2.00
Mar 23 09:49:30 tlondon kernel: usbcore: registered new interface driver snd-usb-audio
Mar 23 09:49:30 tlondon kernel: uvcvideo: Found UVC 1.00 device <unnamed> (046d:0991)
Mar 23 09:49:30 tlondon pulseaudio[3214]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuchProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_46d_991_268AC312_if2
Mar 23 09:49:30 tlondon kernel: input: UVC Camera (046d:0991) as /devices/pci0000:00/0000:00:1a.7/usb1/1-1/1-1:1.0/input/input14
Mar 23 09:49:30 tlondon kernel: usbcore: registered new interface driver uvcvideo
Mar 23 09:49:30 tlondon kernel: USB Video Class driver (v0.1.0)
Mar 23 09:49:31 tlondon pulseaudio[3214]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuchProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_46d_991_268AC312_if0
Mar 23 09:49:31 tlondon pulseaudio[3214]: module-alsa-card.c: Card '1' doesn't exist: Permission denied
Mar 23 09:49:31 tlondon pulseaudio[3214]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id=1 name=usb_device_46d_991_268AC312_if2_sound_card_0 card_name=alsa_card.usb_device_46d_991_268AC312_if2_sound_card_0 tsched=1"): initialization failed.


Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-3.test5.fc11.x86_64


How reproducible:
Every time......

Steps to Reproduce:
1. Plug in usb webcam, watch /var/log/messages
2. check to see if microphone is listed in sound preferences->input
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-03-23 14:27:35 EDT
Not sure its helpful, but:

[root@tlondon v4l]# ls -l /dev/v4l/by-id
total 0
lrwxrwxrwx. 1 root root 12 2009-03-23 10:25 usb-046d_0991_268AC312-video-index0 -> ../../video0
[root@tlondon v4l]# 

[root@tlondon dev]# ls -lZ video0
crw-rw----+ root video system_u:object_r:v4l_device_t:s0 video0
[root@tlondon dev]# getfacl video0
# file: video0
# owner: root
# group: video
user::rw-
user:tbl:rw-
group::rw-
mask::rw-
other::---

[root@tlondon dev]#
Comment 2 Tom London 2009-03-23 17:00:17 EDT
This device is available and recognized if I boot with it connected.

ACLs look the same:

[root@tlondon dev]# ls -lZ video0
crw-rw----+ root video system_u:object_r:v4l_device_t:s0 video0
[root@tlondon dev]# getfacl video0
# file: video0
# owner: root
# group: video
user::rw-
user:tbl:rw-
group::rw-
mask::rw-
other::---

[root@tlondon dev]#
Comment 3 Lennart Poettering 2009-03-24 15:19:19 EDT

*** This bug has been marked as a duplicate of bug 489048 ***

Note You need to log in before you can comment on or make changes to this bug.