Bug 491726 - sqlite2 fails to build in F9+
sqlite2 fails to build in F9+
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sqlite2 (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 14:47 EDT by D. Marlin
Modified: 2009-07-01 18:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.8.17-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 18:08:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Address problem using sqlite2 with Tcl-8.5 Based on sqlite2-tcl.diff from OpenSuSE sqlite2-2.8.17-166.3.src.rpm (932 bytes, patch)
2009-03-23 14:47 EDT, D. Marlin
no flags Details | Diff
Correct problem in tcl-1.6 testcase (based on sqlite3 sources) (656 bytes, patch)
2009-03-23 14:51 EDT, D. Marlin
no flags Details | Diff
Add proposed patches and correct an rpmlint warning. (912 bytes, patch)
2009-03-23 14:59 EDT, D. Marlin
no flags Details | Diff

  None (edit)
Description D. Marlin 2009-03-23 14:47:36 EDT
Created attachment 336347 [details]
Address problem using sqlite2 with Tcl-8.5
Based on sqlite2-tcl.diff from OpenSuSE sqlite2-2.8.17-166.3.src.rpm

Description of problem:

The sqlite2 package fails to build in F9+ using the last available sources.  Although the sources compile, the 'make test' fails.


Version-Release number of selected component (if applicable):

sqlite2-2.8.17-1


How reproducible:

Always


Steps to Reproduce:
1.  rpm -ivh SRPMS/sqlite2-2.8.17-1.fc6.src.rpm
2.  rpmbuild -bb SPECS/sqlite2.spec

  
Actual results:

    :
date-3.17... Ok
~dmarlin/rpm/BUILD/sqlite-2.8.17/.libs/lt-testfixture: invalid command name "clock"
    while executing
"clock seconds"
    invoked from within
"clock format [clock seconds] -format "%Y-%m-%d" -gmt 1"
    invoked from within
"set now [clock format [clock seconds] -format "%Y-%m-%d" -gmt 1]"
    (file "./test/date.test" line 128)
    invoked from within
"source $testfile"
    ("foreach" body line 4)
    invoked from within
"foreach testfile [lsort -dictionary [glob $testdir/*.test]] {
  set tail [file tail $testfile]
  if {[lsearch -exact $EXCLUDE $tail]>=0} continue
  so..."
    (file "./test/quick.test" line 39)
make: *** [test] Error 1
error: Bad exit status from ~dmarlin/rpm/tmp/rpm-tmp.KInrdO (%build)


Expected results:

All test cases pass.


Additional info:

After correcting this issue, tcl-1.6 testcase fails.
A second patch will be provided.
Comment 1 D. Marlin 2009-03-23 14:51:31 EDT
Created attachment 336351 [details]
Correct problem in tcl-1.6 testcase (based on sqlite3 sources)


The testcase produces an error:

tcl-1.6...
Expected: [1 {syntax error in expression "x*"}]
     Got: [1 {invalid bareword "x"
in expression "x*";
should be "$x" or "{x}" or "x(...)" or ...}]


Using code from the sqlite3 version of the testcase avoids the error.
Comment 2 D. Marlin 2009-03-23 14:59:00 EDT
Created attachment 336355 [details]
Add proposed patches and correct an rpmlint warning.

This adds the two proposed patches to the sqlite2 spec file and corrects an rpmlint warning:

  SPECS/sqlite2.spec:76: W: make-check-outside-check-section make test
Comment 3 Alex Lancaster 2009-03-23 15:18:19 EDT
Is sqlite2 actually used by anything else in Fedora at the moment?  It seems that most things have now been ported to use the main sqlite package (which is at version 3, e.g. in F-10: sqlite-3.5.9-4.fc10.i386).

I did a repoquery check in rawhide, and the following command returned nothing:

repoquery --alldeps --whatrequires --enablerepo=rawhide sqlite2

(this should catch all dependent packages both explicit and implicit)

If this is still an issue with F-9, I'm happy to fix it F-9.
Comment 4 D. Marlin 2009-03-23 15:34:04 EDT
I am not aware of other packages in Fedora 10 that require sqlite2.  I was working on building some packages from GPE on Fedora, and GPE relies heavily on sqlite2.  I was able to build these up through F8.

This is still an issue with F9, but since F10 is out and F11 will be ready soon I used F10 as the basis for my changes.  They should work on F9 as well.
Comment 5 Alex Lancaster 2009-03-23 19:05:04 EDT
According to pkgdb: 

http://admin.fedoraproject.org/pkgdb/packages/name/sqlite2

it looks like there is currently no branch for F-10, which means it may have been blocked from F-10 because of broken deps, although I notice that doesn't appear to be officially "retired" because it would have been on:

https://fedoraproject.org/wiki/Retired_packages

I'll look into it.  Meanwhile I can try applying the patches to devel (rawhide) and F-9 branches.
Comment 6 Alex Lancaster 2009-03-23 19:06:00 EDT
(In reply to comment #4)
> I am not aware of other packages in Fedora 10 that require sqlite2.  I was
> working on building some packages from GPE on Fedora, and GPE relies heavily on
> sqlite2.  I was able to build these up through F8.

Is GPE a package in Fedora (or being packaged for Fedora)?  Or is some third-party and/or proprietary package?
Comment 7 Alex Lancaster 2009-03-23 19:26:40 EDT
scratch koji build with patches in rawhide/F-11 seems to work:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1255537

If we can figure out why F-10 was skipped, I will commit and rebuild in all active branches: F-9, F-10 and rawhide.
Comment 8 Alex Lancaster 2009-03-23 19:31:20 EDT
This package actually hasn't been built since F-7 and hasn't been included (i.e. "tagged") in any releases since then according to koji:

http://koji.fedoraproject.org/koji/packageinfo?packageID=3865

which means it's probably blocked (or otherwise never included) by rel-eng
Comment 9 D. Marlin 2009-03-23 19:58:52 EDT
(In reply to comment #6)
> (In reply to comment #4)
> > I am not aware of other packages in Fedora 10 that require sqlite2.  I was
> > working on building some packages from GPE on Fedora, and GPE relies heavily on
> > sqlite2.  I was able to build these up through F8.
> 
> Is GPE a package in Fedora (or being packaged for Fedora)?  Or is some
> third-party and/or proprietary package?  

GPE is not in Fedora.  It is an Open Source desktop/palmtop environment for small footprint (handheld/netbook) systems:

   http://gpe.linuxtogo.org/

I have been working on building/packaging the basic components of GPE for Fedora, but nothing official.  I started with F7 and continued with F8 (building sqlite2 myself), but after sqlite2 failed to build on F9 I put it on hold.  I was hoping to pick up with F10/F11 and continue, if practical.
Comment 10 Alex Lancaster 2009-03-23 20:18:59 EDT
(In reply to comment #9)
> 
> GPE is not in Fedora.  It is an Open Source desktop/palmtop environment for
> small footprint (handheld/netbook) systems:
> 
>    http://gpe.linuxtogo.org/
> 
> I have been working on building/packaging the basic components of GPE for
> Fedora, but nothing official.  I started with F7 and continued with F8
> (building sqlite2 myself), but after sqlite2 failed to build on F9 I put it on
> hold.  I was hoping to pick up with F10/F11 and continue, if practical.  

Are there any concrete plans in upstream GPE to ultimately port to sqlite 3.x?  I don't mind resurrecting sqlite2 for a few releases to allow time for porting, but it would be nice to ultimately be able to retire it at some point in the future.
Comment 11 D. Marlin 2009-03-23 23:13:19 EDT
There were no plans to migrate to sqlite3 when I last checked (F9 timeframe).  The gist of the response was:

"sqlite2 is required because the API is different from sqlite3. ... It should not be that complicated to port ... to sqlite3 but it's not that important because sqlite2 is maintained and can coexist with sqlite3."

AFAICT, sqlite-2.x is still included in the latest Debian stable releases (as well as unstable), and since GPE is also in the Debian release they probably have little incentive to port to sqlite3.

I will ask again and see if their plans have changed.
Comment 12 Alex Lancaster 2009-03-23 23:53:30 EDT
OK, would you be willing to be co-maintainer of sqlite2, or perhaps you could be primary maintainer, and I would be co-maintainer?  I would prefer the latter as I only took it over to keep it from being removed entirely and don't use it for any of my own packages or projects.
Comment 13 D. Marlin 2009-03-24 00:23:58 EDT
I have posted a query to the GPE list regarding porting to sqlite3 and will post back here when I get a reply.

If they have no plans to port to sqlite3 I would be willing to be co-maintainer of sqlite2.  Since I have not been a Fedora maintainer I will need to become familiar with the process.  Once I am comfortable with the process I would be willing to take on a larger role, if that would be acceptable.
Comment 14 Alex Lancaster 2009-03-24 00:41:18 EDT
(In reply to comment #13)
> I have posted a query to the GPE list regarding porting to sqlite3 and will
> post back here when I get a reply.

Thanks.

> If they have no plans to port to sqlite3 I would be willing to be co-maintainer
> of sqlite2.  Since I have not been a Fedora maintainer I will need to become
> familiar with the process.  Once I am comfortable with the process I would be
> willing to take on a larger role, if that would be acceptable.  

Since you are presumably a Red Hat maintainer, have you not already signed the CLA?  Have you been sponsored yet?  See:

http://fedoraproject.org/wiki/PackageMaintainers/Join

Do you have a username in the Fedora Account System (FAS)?
Comment 15 D. Marlin 2009-03-24 14:54:44 EDT
I am not a Red Hat maintainer, just a contributor.  I am in the Fedora Account System and have signed the CLA, but have not been sponsored yet.
Comment 16 Alex Lancaster 2009-03-24 17:01:54 EDT
(In reply to comment #15)
> I am not a Red Hat maintainer, just a contributor.  I am in the Fedora Account
> System and have signed the CLA, but have not been sponsored yet.  

OK, since this package has been out of the system for a while, it may require a re-review in order to be added back.  If so, you could submit the package for a review which would be the first step towards getting sponsorship.

This is the rel-eng request for unblocking this package:

https://fedorahosted.org/rel-eng/ticket/1426
Comment 17 Alex Lancaster 2009-04-02 04:10:07 EDT
OK, so the sqlite2 has now been unblocked from rawhide by rel-eng and is now built and will be in the next rawhide snapshot:

http://koji.fedoraproject.org/koji/buildinfo?buildID=96323

Let me know if you want to me to make branches for F-9 and F-10 (they will have to be pushed as updates via bodhi to become available).
Comment 18 D. Marlin 2009-04-03 11:35:02 EDT
Thank you for pushing this forward.  I have not had a response to my query to the GPE list, but will post back when (if) I do.

Since no one else was using this in F9/10 I don't see a reason to go back.  I'll do my builds against rawhide and just move forward from there.

Please let me know if I can be of assistance maintaining this going forward.
Comment 19 Alex Lancaster 2009-07-01 18:08:50 EDT
(In reply to comment #18)
> Thank you for pushing this forward.  I have not had a response to my query to
> the GPE list, but will post back when (if) I do.
> 
> Since no one else was using this in F9/10 I don't see a reason to go back. 
> I'll do my builds against rawhide and just move forward from there.
> 
> Please let me know if I can be of assistance maintaining this going forward.  

OK, so sqlite2 is now in both F-11 and rawhide (F-12) with all patches applied, and since you don't think we need to need to backport to F-9 and F-10, I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.