Bug 491736 - Rawhide Xen domU installation fails with AttributeError traceback
Rawhide Xen domU installation fails with AttributeError traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 491750 491776 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 15:17 EDT by Pasi Karkkainen
Modified: 2013-01-10 00:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 16:29:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rawhide-xen-domu-installation-error.jpg (99.83 KB, image/jpeg)
2009-03-23 15:17 EDT, Pasi Karkkainen
no flags Details
rawhide-xen-domu-ks.cfg (692 bytes, application/octet-stream)
2009-03-23 15:20 EDT, Pasi Karkkainen
no flags Details

  None (edit)
Description Pasi Karkkainen 2009-03-23 15:17:50 EDT
Created attachment 336360 [details]
rawhide-xen-domu-installation-error.jpg

Description of problem:
Current rawhide fails to install as 32bit Xen domU. Anaconda gives traceback/error: "AttributeError: InstallInterface instance has no attribute 'icw'"

Version-Release number of selected component (if applicable):
Rawhide as of 2009-03-23.

How reproducible:
Always.

Steps to Reproduce:
1. virt-install -n vm02 -r 1024 --vcpus=1 -f /var/lib/xen/images/vm02.img -s 3 --vnc -p -l "ftp://ftp.funet.fi/pub/mirrors/fedora.redhat.com/pub/fedora/linux/development/i386/os/" -x "ks=http://pasik.reaktio.net/fedora/rawhide-xen-domu-ks.cfg"
2. Wait until anaconda gets into "Finding storage devices" step
3. Done/failed.
  
Actual results:
Installation fails/stops with error message/traceback.

Expected results:
Successful installation.

Additional info:
I'm using CentOS 5.3 dom0.

Screenshot of the anaconda failure is here: 
http://pasik.reaktio.net/fedora/rawhide-xen-domu-installation-error.jpg

Kickstart file I used for installation is here:
http://pasik.reaktio.net/fedora/rawhide-xen-domu-ks.cfg

Both also attached to this bugzilla.
Comment 1 Pasi Karkkainen 2009-03-23 15:20:22 EDT
Created attachment 336362 [details]
rawhide-xen-domu-ks.cfg
Comment 2 Pasi Karkkainen 2009-03-23 15:53:53 EDT
Graphical installation of rawhide without kickstart seems to work.
Comment 3 Chris Lumens 2009-03-23 16:28:04 EDT
*** Bug 491750 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2009-03-23 16:29:50 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 5 Chris Lumens 2009-03-23 20:58:43 EDT
*** Bug 491776 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.