Bug 491742 - custom partition leaves swap as type 83
custom partition leaves swap as type 83
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 15:56 EDT by Eric Paris
Modified: 2009-03-26 11:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 10:57:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
parted-1.8.8-dos-label-swap.patch (738 bytes, patch)
2009-03-23 23:27 EDT, David Cantrell
no flags Details | Diff

  None (edit)
Description Eric Paris 2009-03-23 15:56:32 EDT
Installing F11 from March 23.

On the custom install screen I chose to create my own layout.  Now that install has started I checked out fdisk -l to see if things looked good.  The problem is that my swap partition is listed as type 83.  I expected it to be of type 82 "Linux swap / Solaris"
Comment 1 David Cantrell 2009-03-23 23:26:58 EDT
I've verified that anaconda sets the parted.PARTITION_SWAP flag on the swap partition via pyparted and pyparted is calling libparted to set the PED_PARTITION_SWAP flag.  The problem looks to be in libparted in the DOS disk label code.  It never does anything with the PED_PARTITION_FLAG.  The attached patch may solve the problem.  Haven't tested it, but put it together to describe what I think the problem is.

Reassigning to parted.
Comment 2 David Cantrell 2009-03-23 23:27:26 EDT
Created attachment 336419 [details]
parted-1.8.8-dos-label-swap.patch
Comment 3 Joel Andres Granados 2009-03-26 10:57:34 EDT
This will be available in the next parted version 1.8.8-15.
Comment 4 Joel Andres Granados 2009-03-26 11:00:21 EDT
parted 1.8.8-16 is the next version, sorry.

Note You need to log in before you can comment on or make changes to this bug.