Bug 49176 - anaconda crashes trying to mount already-mounted iso image
anaconda crashes trying to mount already-mounted iso image
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-16 12:00 EDT by Thomas Quinn
Modified: 2010-06-02 10:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 15:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Quinn 2001-07-16 12:00:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17 i686)

Description of problem:
When I try to upgrade from Redhat 7.0 to Redhat 7.1 on an IDE disk from iso
images on a second IDE drive, I first get a message about not enough disk
space.  After making room by either paring down the package list or
removing files using the shell in virtual console 2, and retrying the
upgrade, anaconda crashes with the traceback given below.

How reproducible:
Always

Steps to Reproduce:
1.  Place Redhat 7.1 ISO images on 2nd IDE drive
2.  Create boot floppy from boot.img
3.  Boot from floppy to start upgrade.
4.  Select upgrade.
5.  Start upgrade, get message about not enough disk space.
6.  Go back to Customize packages; deselect packages until disk use is
small enough.
7.  Retry upgrade.

Actual Results:  anaconda crashes and gives a traceback.

Expected Results:  The system should have been upgraded with packages for
RedHat 7.1

Additional info:

Here is the traceback:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in
__call__
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1773, in
doInstal
l
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/harddrive.py", line 181, in
merg
eFullHeaders
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/harddrive.py", line 101, in
moun
tMedia
SystemError: trying to mount already-mounted iso image!

Local variables in innermost frame:
self: <harddrive.HardDriveInstallMethod instance at 825f850>
cdNum: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(itext
ProgressWindow
(dp5
S'scale'
p6
NsS'screen'
p7
(isnack
SnackScreen
p8
(dp9
S'height'
p10
I37
sS'width'
p11
I100
sS'helpCb'
p12

<failed>
Comment 1 Brent Fox 2001-07-25 13:15:20 EDT
Aha!  This looks like a dupe of bug #38214, which we could never figure out, but
it looks like you have shed new light on the problem.  When you did the upgrade,
did you select additional packages to be installed or did you let the install
just upgrade packages that were already on your system?
Comment 2 Thomas Quinn 2001-07-25 15:25:42 EDT
When I did the upgrade, I let the install just upgrade packages that were on my
system.  In addition I 
DEselected a number of packages in a (failed) attempt to get the upgrade to fit
within the available disk space.  It was after I went back to the "Customized
packages" screen the second time to deselect more packages and tried the upgrade
again, that   I got the reported crash.

Also note: I was ultimately successful in upgrading my machine:  I started from
booting from the floppy, and deselect a sufficient number of packages for it to
fit on disk on the first upgrade attempt, and it completed successfully.
Comment 3 Brent Fox 2001-07-26 14:19:43 EDT
Woohoo!  We have a fix for this now in cvs.  It was never clear before that the
problem was caused by trying to install, finding out there wasn't enough space,
then removeing some packages, and then going forward.  This should work properly
in future releases.  Thanks for your report.  You've helped solve a bug that has
nagged me for months.
Comment 4 jmiller10101010 2010-06-02 10:29:58 EDT
What was the fix?

I have a similar Problem with anaconda, but I can't fathom what the big Problem with Remounting is?

Note You need to log in before you can comment on or make changes to this bug.