Bug 491762 - Package profile compare w/ profile created by api gets 500 ise
Package profile compare w/ profile created by api gets 500 ise
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
wes hayutin
https://riverraid.rhndev.redhat.com/r...
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-23 17:44 EDT by wes hayutin
Modified: 2009-09-10 16:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snippet from tomcat logs (36.78 KB, application/octet-stream)
2009-03-23 17:44 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-03-23 17:44:19 EDT
Created attachment 336394 [details]
snippet from tomcat logs

Description of problem:

Satellite-5.3.0-RHEL5-re20090317.0-i386-embedded-oracle.iso
Package profile compare w/ profile created by api gets 500 ise

recreate.
1. register a sysytem
2. create package profile
3. install package
4. compare system to profile .. success :)

5. register a system w/ api
6. compare package profile w/ system profile created by api...

NOT SURE IF THIS IS RE-CREATABLE...
Brad, wanted to take a look.. so opening..
Comment 1 wes hayutin 2009-03-23 17:45:48 EDT
The following exception occurred while executing this request:
GET /rhn/systems/details/packages/profiles/CompareSystems.do

Date:3/23/09 5:39:01 PM EDT
Headers:
  host: riverraid.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2) Gecko/20090227 Fedora/3.1-0.7.beta2.fc11 Minefield/3.1b2
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,en;q=0.5
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://riverraid.rhndev.redhat.com/rhn/systems/details/packages/profiles/ShowProfiles.do?sid=1000010178
  cookie: JSESSIONID=CCB0482910C1C9E2D542C2906F919BD0; rh_omni_tc=70160000000H4AjAAK; __qca=1236177970-15367291-11166117; s_vi=[CS]v1|49B3C004000024CC-A3A0980000010C0[CE]; s_cc=true; s_sq=%5B%5BB%5D%5D; rh_sso=0|aYNLk6sOj5WTzmXaY2Cke3zebJ9qwY0WkjF; rh_user=whayutin|Stephen3|member; rh_shared_auth=1e0cbcd51c0ad0de368c8ec010955bc81d0ecd701e8c10d85337bab197166efb587f8a271a66d5ec2b507729bd5f3ab5b946df0ac4d343109b7b5f71661701efb63cb92c455ca41453a45e0c7a266fc8; pxt-session-cookie=1173xaabc516f9f64ba3c198e4533d0e445e4

Request:
Local Name = riverraid.rhndev.redhat.com
Server Name = riverraid.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@3e043e04[session=StandardSession[CCB0482910C1C9E2D542C2906F919BD0]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.error.message, javax.servlet.request.key_size, javax.servlet.request.ssl_session, __sitemesh__page, javax.servlet.request.cipher_suite, org.apache.struts.action.MESSAGE, javax.servlet.error.exception, javax.servlet.error.servlet_name, org.apache.struts.action.MODULE, system, __sitemesh__filterapplied, javax.servlet.error.status_code, javax.servlet.error.request_uri, session, org.apache.struts.action.mapping.instance, systemname, requestedUri, 


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: null
        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
        at java.lang.Thread.run(Thread.java:735)
Caused by: java.lang.NumberFormatException: null
        at java.lang.Throwable.<init>(Throwable.java:67)
        at java.lang.Integer.parseInt(Integer.java:425)
        at java.lang.Integer.parseInt(Integer.java:508)
        at com.redhat.rhn.manager.profile.ProfileManager.epochcmp(ProfileManager.java:1215)
        at com.redhat.rhn.manager.profile.ProfileManager.vercmp(ProfileManager.java:1184)
        at com.redhat.rhn.manager.profile.ProfileManager.compareAndCreatePackageMetaData(ProfileManager.java:451)
        at com.redhat.rhn.manager.profile.ProfileManager.comparePackageLists(ProfileManager.java:347)
        at com.redhat.rhn.manager.profile.ProfileManager.compareServerToServer(ProfileManager.java:507)
        at com.redhat.rhn.frontend.action.rhnpackage.profile.CompareSystemSetupAction.getDataResult(CompareSystemSetupAction.java:134)
        at com.redhat.rhn.frontend.action.rhnpackage.profile.CompareSystemSetupAction.execute(CompareSystemSetupAction.java:81)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 40 more
Comment 2 Brad Buckingham 2009-03-24 14:27:29 EDT
git commit: 1aad37f79cfc242aa4a3752f46b0d70f4a1bef4c

Even though the test case involved a system created using the internal APIs, the error is one that should not have occurred.  The error was in the logic to perform the comparison of the epoch values between the system and profile.  If the second epoch in the comparison was null, an ISE would be generated.

Note: I was able to reproduce this issue doing both a comparison of system-system and system-profile.
Comment 3 Brad Buckingham 2009-04-01 10:35:59 EDT
mass move to ON_QA
Comment 4 wes hayutin 2009-04-23 13:00:53 EDT
verified 422.2 build
Comment 5 Sayli Karmarkar 2009-08-25 19:46:14 EDT
validated on stage.
Comment 6 Brandon Perkins 2009-09-10 16:34:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.