Bug 491804 - ardour2 window maximize does not respect gnome-panel sidebar
ardour2 window maximize does not respect gnome-panel sidebar
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ardour (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 01:24 EDT by Jane Dogalt
Modified: 2009-06-02 19:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 19:04:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jane Dogalt 2009-03-24 01:24:59 EDT
Description of problem:

When ardour starts, it is maximized to the entire screen size, not respecting the gnome-panel sidebar on the left (unlike gnome-terminal and every other application).  What is worse, is it seems ardour does not even allow window width resizing.  Clarification- it does respect gnome-panel in that it doesn't overlap with it, but there is the gnome-panel width worth of the ardour window not visible past the right edge of the screen.

Version-Release number of selected component (if applicable):

ardour-2.6.1-1.fc10.i386

How reproducible:

very


Steps to Reproduce:
1. configure a gnome-panel on the left side of screen
2. launch ardour
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jane Dogalt 2009-03-24 01:28:18 EDT
minor clarification on reproduction-

you may have to be in a state where it can start jackd, and you also need to create a new session with arbitrary name.  Once the new session is created, is when the quasi-fullscreen window appears.
Comment 2 Orcan Ogetbil 2009-03-24 02:05:58 EDT
Could you try this with ardour-2.7.1 from the testing repo?
   
   yum --enablerepo updates-testing update ardour
Comment 3 Jane Dogalt 2009-03-25 00:35:58 EDT
No, that 2.7.1 didn't do the trick, same behavior.

Also, in case it matters, my display is 1280x800.
Comment 4 Orcan Ogetbil 2009-04-01 10:11:59 EDT
As far as I know, ardour is designed to fit e screen width of 1024. You shouldn't be able to make the window smaller than 1024 pixels in width, but you can make it larger than that.

Ah, I'll try to verify the problem. But I have to install Gnome first. I'm scared.
Comment 5 Jane Dogalt 2009-04-01 23:16:17 EDT
(In reply to comment #4)
> As far as I know, ardour is designed to fit e screen width of 1024. You
> shouldn't be able to make the window smaller than 1024 pixels in width, but you
> can make it larger than that.
> 
> Ah, I'll try to verify the problem. But I have to install Gnome first. I'm
> scared.  

Thanks for looking at this.  I did dig into the code myself hoping I could make a quick fix, but I got scared too...  I think the problem lies with its use of gdk_get_screen_size or some such.  There is also some hardcoded check for screen widths less than 1200 (didn't see 1024 mentioned anywhere).  In any event, my screen width is 1280 so I should be 'fine' as far as that case is concerned.

I think the problem lies with all that logic, which seems to preclude generic resizability.  I.e. gnome-terminal and every other app I try doesn't have a problem because when metacity(windowmanager) maximizes it, it maximizes it to the space minus the gnome panel.  Whereas ardour is playing pretty tight with getting the actual screen width, and then not letting the user resize.  Basically I'm pretty sure that is the central problem, and the code dealing with such stuff was not isolated to just one place where I could try a few-line fix.  (or thats my brief perusal assessment, FWIW).
Comment 6 Orcan Ogetbil 2009-04-04 23:13:21 EDT
OK, I finally installed Gnome and reproduced your case in 1280xheight resolutions.
It looks like this is a feature of ardour rather than a bug. I did not encounter this before because I use a resolution of 1680x1050.

Nevertheless, this is not a packaging bug. I reported it to upstream for you. You can follow the ticket here:
   http://tracker.ardour.org/view.php?id=2613

I'll backport the "fix" if it is ever going to be fixed.
Comment 7 Orcan Ogetbil 2009-06-02 19:04:59 EDT
I talked to the main author of the ardour. This is a font scaling problem of GTK/pango. 

In ardour, go to

"Edit -> Preferences -> Misc -> Font scaling"

By playing with that slider I was able to fit ardour in much smaller screen widths. So I'm closing the bug NOTABUG. Feel free to reopen it if you still think that there is something wrong.

Note You need to log in before you can comment on or make changes to this bug.