Bug 491828 - the storage pool with the same uuid could be defined without no error prompt
the storage pool with the same uuid could be defined without no error prompt
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Dave Allan
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 06:43 EDT by Vivian Bian
Modified: 2016-04-26 09:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-14 11:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the test-storage-pool definition file (340 bytes, text/xml)
2009-03-24 06:43 EDT, Vivian Bian
no flags Details
test-storage-vbian pool definition file (317 bytes, text/xml)
2009-03-24 06:44 EDT, Vivian Bian
no flags Details

  None (edit)
Description Vivian Bian 2009-03-24 06:43:04 EDT
Created attachment 336445 [details]
the test-storage-pool definition file

Description of problem:
the storage pool with the same uuid could be defined without no error prompt,but only says this pool is already active after the first one is active,and tried to start the second one

Version-Release number of selected component (if applicable):
libvirt-0.5.1-3.el5ovirt

How reproducible:
Always

Steps to Reproduce:
# iscsiadm --mode discovery --type sendtargets --portal 10.66.70.7:3260
# iscsiadm --mode node --targetname storage-vbian --portal 10.66.70.7 --login
# iscsiadm --mode discovery --type sendtargets --portal 10.66.70.36:3260
# iscsiadm --mode node --targetname storage-vbian --portal 10.66.70.36 --login
# virsh pool-define storage_pool.xml
# virsh pool_define storage_pool_vbian.xml
# virsh pool-list --all
# virsh pool-start test-storage-pool
# virsh pool-start test-storage-vbian

  
Actual results:
the test-storage-vbian could not be active

Expected results:
the test-storage-vbian pool could not be defined if its uuid is the same with the test-storage-pool's

Additional info:
Comment 1 Vivian Bian 2009-03-24 06:44:16 EDT
Created attachment 336446 [details]
test-storage-vbian pool definition file
Comment 2 Perry Myers 2009-03-30 23:22:00 EDT
Moving to RHEL since libvirt is not supported in RHEV1.0 production builds and this problem will need to be addressed in RHEL5.4 release
Comment 3 Daniel Berrange 2009-10-29 13:06:15 EDT
The storage pool driver is not checking for duplicated UUID in the XML. Nor is it checking for duplicated iSCSI portal addresses. We need to add some of these safety checks into the storage driver, and associated tests to the TCK
Comment 4 Dave Allan 2009-12-14 11:49:52 EST
I have tried to define pools with duplicate UUID with dir and iscsi backends on both the upstream head and libvirt-0.6.3-24, and in all cases the duplicate UUID was rejected, so I'm closing this bug.  If you find that you can reproduce it, please reopen.  I have opened bug 547431 to track Dan's request for rejection of duplicate pool sources.

Note You need to log in before you can comment on or make changes to this bug.