Bug 491831 - rhn-satellite-activate says Pushing scout configs to all monitoring scouts even if monitoring not enabled
rhn-satellite-activate says Pushing scout configs to all monitoring scouts ev...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
: Regression
Depends On:
Blocks: 463877
  Show dependency treegraph
 
Reported: 2009-03-24 07:09 EDT by Jan Pazdziora
Modified: 2009-09-10 14:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:49:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-03-24 07:09:14 EDT
Description of problem:

When I run rhn-satellite-activate, message

Pushing scout configs to all monitoring scouts

shown even if monitoring is not enabled on the Satellite.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090323.0 on i386
# type rhn-satellite-activate
rhn-satellite-activate is hashed (/usr/bin/rhn-satellite-activate)
# rpm -qf /usr/bin/rhn-satellite-activate
spacewalk-backend-tools-0.5.25-1.el5sat

How reproducible:

Tried once.

Steps to Reproduce:
1. Run rhn-satellite-activate --rhn-cert=redhat-internal-devel.cert\?rev\=177728 on Satellite server which does not have monitoring enabled.
  
Actual results:

# rhn-satellite-activate --rhn-cert=redhat-internal-devel.cert\?rev\=177728 
RHN_PARENT: satellite.rhn.webqa.redhat.com
Pushing scout configs to all monitoring scouts
# 

Expected results:

# rhn-satellite-activate --rhn-cert=redhat-internal-devel.cert\?rev\=177728 
RHN_PARENT: satellite.rhn.webqa.redhat.com
# 

Additional info:

This is a possible regression.
Comment 1 Miroslav Suchý 2009-03-24 08:30:19 EDT
IMO not regression, suggesting to punt to sat-540
Comment 2 Jan Pazdziora 2009-03-25 10:16:35 EDT
I just did a fresh disconnected install of Satellite 5.2.0 (from Satellite-5.2.0-RHEL5-re20081028.3-i386 compose), then added server.satellite.rhn_parent and commented out disconnected=1 from /etc/rhn/rhn.conf.

Then I run:

# rhn-satellite-activate --rhn-cert=cert.52 
RHN_PARENT: satellite.rhn.webqa.redhat.com
#

Therefore, I consider this a Regression against 5.2.0. Thus, setting Keyword and putting back to triage for reconsideration.

The reason I'd like this bugzilla addressed for 5.3.0 is that I suspect that something got changed for worse with monitoring and monitoring scout setups and/or activation, so Satellite now things there are some scouts there even if there aren't any. The rhn-satellite-activate output might be just one symptom of this problem which can bite us elsewhere. Obviously, the proper fix is not to silence the output but address whatever reason rhn-satellite-activate found to print it in the first place.
Comment 3 Brandon Perkins 2009-03-26 12:30:58 EDT
Approving this more for investigation of why the behavior change.  Obviously if its just printing a message, that's not bad.  If we're doing something wrong or in the wrong place, that is bad and needs to be fixed.
Comment 4 Miroslav Suchý 2009-05-22 05:50:19 EDT
Dunno how it was possible that it worked previously. But we check if monitoring is enabled by checking if package NPalert is installed. Which is wrong
Fixed by commit fb81c8b01cf2c743318b24fe9a8717d61851e9c5.
The message itself is quite harmless and is introduced by BZ 163392.
Anyway now this message should be printed only if monitoring backend is enabled.

Will be fixed in spacewalk-backend-tools-0.5.28-16.el5sat
Comment 5 Preethi Thomas 2009-06-04 16:40:04 EDT
verified

with monitoring disabled
[root@rlx-3-24 ~]# rhn-satellite-activate --rhn-cert=/root/redhat-internal-devel.cert  -vvv
RHN_PARENT: satellite.rhn.webqa.redhat.com
HTTP_PROXY: None
HTTP_PROXY_USERNAME: None
HTTP_PROXY_PASSWORD: <password>
CA_CERT: /usr/share/rhn/RHNS-CA-CERT
Checking cert XML sanity and GPG signature: '/usr/bin/validate-sat-cert.pl --keyring /etc/webapp-keyring.gpg /etc/sysconfig/rhn/rhn-entitlement-cert.xml-24756-1244146510.71567202'
Database connectioned initialized: refer to default_db setting in /etc/rhn/rhn.conf
Attempting local RHN Certificate push (and therefore activation)
Executing: remote XMLRPC deactivation (if necessary).
Executing: remote XMLRPC activation call.
Executing: '/usr/bin/satellite-sync --list-channels --ca-cert /usr/share/rhn/RHNS-CA-CERT'


with monitoring enabled

[root@rlx-3-24 ~]# rhn-satellite-activate --rhn-cert=/root/cert.53 -vv
RHN_PARENT: satellite.rhn.webqa.redhat.com
HTTP_PROXY: None
HTTP_PROXY_USERNAME: None
HTTP_PROXY_PASSWORD: <password>
CA_CERT: /usr/share/rhn/RHNS-CA-CERT
Checking cert XML sanity and GPG signature: '/usr/bin/validate-sat-cert.pl --keyring /etc/webapp-keyring.gpg /etc/sysconfig/rhn/rhn-entitlement-cert.xml-26538-1244147749.18229890'
Database connectioned initialized: refer to default_db setting in /etc/rhn/rhn.conf
Attempting local RHN Certificate push (and therefore activation)
Pushing scout configs to all monitoring scouts
Executing: remote XMLRPC deactivation (if necessary).
Executing: remote XMLRPC activation call.
Executing: '/usr/bin/satellite-sync --list-channels --ca-cert /usr/share/rhn/RHNS-CA-CERT'
Comment 6 Brad Buckingham 2009-08-06 17:53:02 EDT
verified with 7/24 stage iso... moving to RELEASE_PENDING

used same verification procedure as #5
Comment 7 Brandon Perkins 2009-09-10 14:49:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.