Bug 491850 - rhn/up2date crash
rhn/up2date crash
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-applet (Show other bugs)
5.2
i386 Linux
low Severity urgent
: rc
: ---
Assigned To: John Matthews
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 09:15 EDT by Landtax
Modified: 2009-03-24 12:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 12:16:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date crash info (2.17 KB, application/octet-stream)
2009-03-24 09:17 EDT, Landtax
no flags Details

  None (edit)
Description Landtax 2009-03-24 09:15:37 EDT
Description of problem: getting attached error when running up2date


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Landtax 2009-03-24 09:17:01 EDT
Created attachment 336459 [details]
up2date crash info
Comment 2 John Matthews 2009-03-24 10:05:53 EDT
The error appears to be caused by a cert file not being found.

SSLCertificateFileNotFound: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-
ORG-TRUSTED-SSL-CERT


Check: /etc/sysconfig/rhn/up2date
Your value for "sslCACert" is most likely:
sslCACert[comment]=The CA cert used to verify the ssl server
sslCACert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT


If you are connecting to a Satellite you need to change this value to point to the ssl cert you want to use.
Comment 3 Landtax 2009-03-24 12:09:10 EDT
(In reply to comment #2)
hi matthew
thank you
i compared the file to an old one and notice that a change was made.
i just reverse the change and it is working again
thank you
Comment 4 John Matthews 2009-03-24 12:16:09 EDT
Glad to hear your problem was resolved.

Note You need to log in before you can comment on or make changes to this bug.