Bug 491860 - [RHEL4.8 Beta] VideoRAM of MGA G200e is not recognized correctly
[RHEL4.8 Beta] VideoRAM of MGA G200e is not recognized correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.8
All Linux
urgent Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks: 391511
  Show dependency treegraph
 
Reported: 2009-03-24 09:29 EDT by Alan Matsuoka
Modified: 2010-10-23 04:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 09:49:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport-Tuxedo2E-464637-39da1c.tar.bz2 (654.48 KB, application/x-bzip2)
2009-03-24 09:29 EDT, Alan Matsuoka
no flags Details
Xorg.0_rhel47.log (37.53 KB, text/x-log)
2009-03-24 09:29 EDT, Alan Matsuoka
no flags Details
Xorg.0_rhel48.log (38.77 KB, text/x-log)
2009-03-24 09:31 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2009-03-24 09:29:10 EDT
Created attachment 336462 [details]
sosreport-Tuxedo2E-464637-39da1c.tar.bz2

Description of problem:
The capacity of VideoRAM is recognized as 2048KB on the machine equipped with
MGA G200e with 8MB memory.
This problem occur on both i386 and x86_64.

The capacity of VideoRAM is recognized as 8128KB on RHEL4.7 GA,
so this problem is a regression.

Version-Release number of selected component (if applicable):
RHEL4.8 Beta
 kernel-smp-2.6.9-82.EL
 xorg-x11-6.8.2-1.EL.62

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4.8 GA, and reboot
2. Display X-Window screen.
3. Check /var/log/Xorg.0.log

  The capacity of VideoRAM is recognized as 2048KB.

Actual results:
The capacity of VideoRAM is recognized as 2048KB.

Expected results:
The capacity of VideoRAM is recognized as 8128KB.

Business impact:
This is a regression issue which affects servers already shipped.

Hardware info:
Machine : Express5800/110Ri-1
CPU     : Intel(R) Xeon(R) CPU X3350 2.66GHz x 1
Memory  : 6.5GB

See attached sosreport for details.

Additional info:
- The capacity of VideoRAM is recognized as 2048KB on the machine equipped with
 MGA G200e with 1.7MB memory.
 However, it is recognized as 1696KB on RHEL4.7 GA.
- We attach Xorg.0.log of both RHEL4.8 Beta and RHEL4.7 GA.

 Xorg.0_rhel48.log : Xorg.0.log of RHEL4.8 Beta
 Xorg.0_rhel47.log : Xorg.0.log of RHEL4.7 GA

**** Regressions ****

>  1. What is the last known working version (specific
>     name-version-release) of the package?
> Very sorry, this information will comes later (Now asking exact version on RHEL4.7 for NEC).

xorg-x11-6.8.2-1.EL.52

>  3. Please paste the contents of the change log between these two
>     versions. Not the entire changelog contents. (rpm -qp [package]
>     --changelog
> This information will comes later (Aasking for NEC, too).

----
2009-03-06 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.62:
- xorg-x11-6.8.2-mga-g200se-dont-force-16bpp.patch: Fix option parsing to
work (and not be quite so crashy). (#485156)

2009-02-12 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.60:
- xorg-x11-6.8.2-mga-g200se-dont-force-16bpp.patch: Do vram probe
earlier, and fix inverted test sense. (#485156)

2009-02-12 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.61:
- xorg-x11-6.8.2-dev-input-mice.patch: Try /dev/input/mice when
searching for automatic mouse device. (#485305)

2009-01-28 22:00:00
Dave Airlie <airlied@redhat.com> 6.8.2-1.EL.59:
- xorg-x11-6.8.2-fix-powerpc-fonts.patch (#300911)

2009-01-27 22:00:00
Kristian Høgsberg <krh@redhat.com> 6.8.2-1.EL.58:
- Fix segfault on xfs drone server exit path.
- Update Sun6 keyboard patch to not drop the \| key.

2009-01-23 22:00:00
Dave Airlie <airlied@redhat.com> 6.8.2-1.EL.57:
- xorg-x11-6.8.2-xkbcomp-add-ibm_spacesaver.patch (#454831)
- xorg-x11-6.8.2-mga-g200se-dont-force-16bpp.patch (#469651)

2009-01-12 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.56:
- xorg-x11-6.8.2-g200-ev-wb.patch: Add support for Maxim and Winbond
variants. (#445498, #454780)

2009-01-08 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.55:
- Fix libGLU.a build on x86_64. (#432087)

2008-12-08 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.53:
- xorg-x11-6.8.2-drm-device-permissions.patch: Fix initial DRI device
permissions. (#462106)

2008-12-08 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.54:
- xorg-x11-6.8.2-fb-traps-crash.patch: Fix crash in trapezoid rendering
triggered by Firefox, among other things. (#463137)
----
Comment 1 Alan Matsuoka 2009-03-24 09:29:38 EDT
Created attachment 336463 [details]
Xorg.0_rhel47.log
Comment 2 Alan Matsuoka 2009-03-24 09:31:08 EDT
Created attachment 336464 [details]
Xorg.0_rhel48.log
Comment 3 RHEL Product and Program Management 2009-03-24 09:31:32 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Adam Jackson 2009-03-25 10:31:59 EDT
Please test:

http://people.redhat.com/~ajackson/xorg-x11-6.8.2-1.EL.62.jx1/
Comment 6 Adam Jackson 2009-03-26 17:06:20 EDT
Oops, incomplete fix.  Please test:

http://people.redhat.com/~ajackson/xorg-x11-6.8.2-1.EL.62.jx2/
Comment 7 Issue Tracker 2009-04-09 04:32:46 EDT
Hi,

NEC reported there's no problem on RHEL4.8 Snapshot 3.

----
We confirmed that this problem was resolved on RHEL4.8 Snapshot3
----

Regards,
Masaki Furuta


This event sent from IssueTracker by mfuruta@redhat.com 
 issue 278328
Comment 8 Chris Ward 2009-04-14 09:49:37 EDT
Fix confirmed. Closing CURRENTRELEASE.
Comment 10 Chris Ward 2009-04-15 05:03:43 EDT
This bug was never accepted into the release, but was confirmed to have been fixed anyway. If there are remaining issues relating to this bug, please let me know.
Comment 11 Issue Tracker 2009-04-19 22:34:39 EDT
Ishida-san,

This will go including RHEL4.8 and I'll keep it open till RHEL4.8
released.
If you encounter any issues, please let me know asap.

Regards,
Masaki Furuta 


This event sent from IssueTracker by mfuruta@redhat.com 
 issue 278328

Note You need to log in before you can comment on or make changes to this bug.