Bug 491890 - Addition of site.xml to the CSP URL: support.redhat.com/jbossnetwork/updates
Addition of site.xml to the CSP URL: support.redhat.com/jbossnetwork/updates
Status: CLOSED WONTFIX
Product: JBoss Customer Support Portal
Classification: Retired
Component: Web-General (Show other bugs)
1.4
All All
urgent Severity medium
: ---
: ---
Assigned To: Nathan Lugert
David Spalding
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 10:58 EDT by Tom Mirc
Modified: 2015-01-19 19:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-05 13:34:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requirements for future site (19.22 KB, application/vnd.oasis.opendocument.text)
2009-03-26 13:25 EDT, Tom Mirc
no flags Details

  None (edit)
Description Tom Mirc 2009-03-24 10:58:46 EDT
Description of problem:

Before the next product release of JBDS 2.0.0.GA the JBDS dev team needs a dedicated URL where a site.xml containing the XML tags:
   <?xml version="1.0" encoding="UTF-8"?><site/>  is stored.  

AM has provided the URL: support.redhat.com/jbossnetwork/updates.

The only work that needs to occur via this bug is the above XML is included when the above supplied URL is accessed.

This site will be referenced via Eclipse to provide automated JBDS/Eclipse updates.  This functionality is a primary marketing feature that has been publicized.  

Version-Release number of selected component (if applicable):


How reproducible:

NA

Steps to Reproduce:

1. Secure URL support.redhat.com/jbossnetwork/updates
2. Post xml text to site: <?xml version="1.0" encoding="UTF-8"?><site/> 
3. Test and verify that accessing the URL responds with the XML text
  
Additional info:

As product development occurs, this will become a robust site.xml with .jar files for features, plug-ins and p2 metadata.
Comment 1 Tom Mirc 2009-03-26 13:25:56 EDT
Created attachment 336851 [details]
Requirements for future site
Comment 2 Tom Mirc 2009-03-26 13:29:31 EDT
Nick Boldt, Prakash Aradhya, Max Andersen, Mark Cox and Paul Gampe have been in extensive conversations around security and various other issues since December 08.  Mark is comfortable around the jar signing features of the update site proposed by Nick and Max as of mid March.
Comment 3 David Spalding 2011-01-05 13:34:29 EST
Superceded by Avalon. This component is no longer valid.

Note You need to log in before you can comment on or make changes to this bug.