Bug 491947 - Excludes always processed on localinstall pkgs, even with --disableexcludes=all
Excludes always processed on localinstall pkgs, even with --disableexcludes=all
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 14:57 EDT by Gerry Reno
Modified: 2014-01-21 18:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-09 16:24:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Reno 2009-03-24 14:57:20 EDT
Description of problem:
I have a pkg excluded in /etc/yum.conf but even though I override this exclusion by using the --disableexcludes=all option, yum still will not let me do:

yum localinstall --disableexcludes=all  /path/pkg
...
Nothing to do.


If I comment out the pkg in /etc/yum.conf then the pkg will localinstall. 



Version-Release number of selected component (if applicable):
yum-3.2.21-2.fc10.noarch

How reproducible:
always

Steps to Reproduce:
1. see description
2.
3.
  
Actual results:
doesn't localinstall pkg

Expected results:
localinstall pkg succeeds

Additional info:
Comment 1 seth vidal 2009-10-09 16:24:06 EDT
Found this and submitted a patch that fixes this upstream.

thanks.
also reassigning this to yum since it isn't a yum-utils bug.

Note You need to log in before you can comment on or make changes to this bug.