This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 491983 - configure to log to syslog by default
configure to log to syslog by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fail2ban (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 16:20 EDT by Matthew Miller
Modified: 2009-09-15 03:56 EDT (History)
0 users

See Also:
Fixed In Version: 0.8.4-23.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 00:03:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2009-03-24 16:20:20 EDT
Currently (and by default) fail2ban writes to its own log file at /var/log/fail2ban.log. However, simply changing the /etc/fail2ban/fail2ban.conf config file to

  logtarget = SYSLOG

will make it log to syslog. I've tested it and it works just fine.

This has several big advantages. There's no need for a separate logrotate configuration file. More importantly, it works with remote logging with no further magic -- you can just send the information to a standard log server.
Comment 1 Bug Zapper 2009-06-09 08:35:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Axel Thimm 2009-08-27 14:35:05 EDT
fail2ban doesn't work properly on python 2.6, I think this is just another duplicate of bug #508171.
Comment 3 Axel Thimm 2009-08-27 14:36:22 EDT
(In reply to comment #2)
> fail2ban doesn't work properly on python 2.6, I think this is just another
> duplicate of bug #508171.  

Please ignore this comment, it was intended for bug 498149.
Comment 4 Fedora Update System 2009-08-27 16:28:11 EDT
fail2ban-0.8.3-21.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/fail2ban-0.8.3-21.fc10
Comment 5 Fedora Update System 2009-08-27 16:28:25 EDT
fail2ban-0.8.3-21.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/fail2ban-0.8.3-21.fc11
Comment 6 Fedora Update System 2009-08-28 17:58:54 EDT
fail2ban-0.8.3-21.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fail2ban'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9094
Comment 7 Fedora Update System 2009-08-28 17:59:52 EDT
fail2ban-0.8.3-21.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fail2ban'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9103
Comment 8 Fedora Update System 2009-09-04 00:02:39 EDT
fail2ban-0.8.3-22.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-09-11 06:57:07 EDT
fail2ban-0.8.4-23.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/fail2ban-0.8.4-23.fc11
Comment 10 Fedora Update System 2009-09-11 06:57:30 EDT
fail2ban-0.8.4-23.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/fail2ban-0.8.4-23.fc10
Comment 11 Fedora Update System 2009-09-15 03:49:48 EDT
fail2ban-0.8.4-23.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-09-15 03:55:54 EDT
fail2ban-0.8.4-23.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.