Bug 491988 - 1892994 - GFS2 File System Corruption in RHEL5.3
1892994 - GFS2 File System Corruption in RHEL5.3
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Chris Feist
Cluster QE
: ZStream
Depends On: 490136
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 16:45 EDT by Benjamin Kahn
Modified: 2010-01-11 22:42 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 12:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the problem (101.15 KB, patch)
2009-03-25 17:35 EDT, Robert Peterson
no flags Details | Diff

  None (edit)
Description Benjamin Kahn 2009-03-24 16:45:49 EDT
This bug has been copied from bug #490136 and has been proposed
to be backported to 5.2 z-stream (EUS).
Comment 6 Robert Peterson 2009-03-25 17:35:48 EDT
Created attachment 336711 [details]
Patch to fix the problem

Due to the large number of bugs fixed between 5.2 and 5.3, the
crosswrite patch required I pull in a bunch of code from other
patches.  Thus, this patch for 5.2 is quite big.
Comment 7 Robert Peterson 2009-03-25 18:03:41 EDT
It passes all the gfs2_convert tests, which also exercise gfs2_fsck.
I pushed it to the RHEL52 branch of the cluster git tree.  Reassigning
to Chris Feist for the z-stream process.
Comment 8 Chris Feist 2009-03-26 17:38:15 EDT
Built in gfs2-utils-0.1.44-1.el5_2.2
Comment 10 Nate Straz 2009-03-27 12:33:23 EDT
Applying a qa_nak on this since GFS2 was not supported on 5.2 and the customer has not asked for this fix.
Comment 11 RHEL Product and Program Management 2009-03-27 12:44:50 EDT
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.