Bug 491997 - Traceback on EFI partitioning
Traceback on EFI partitioning
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:f75f85bc1a0ce6fed...
:
: 492026 492106 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 17:56 EDT by Jesse Keating
Modified: 2013-01-09 22:28 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 13:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (137.18 KB, text/plain)
2009-03-24 17:56 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2009-03-24 17:56:31 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.36 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 194, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/tmp/updates/storage/partitioning.py", line 609, in allocatePartitions
    partedDisk.removePartition(_part.partedPartition)
  File "/tmp/updates/storage/partitioning.py", line 945, in growPartitions
    allocatePartitions(disks, partitions)
  File "/tmp/updates/storage/partitioning.py", line 554, in doPartitioning
    growPartitions(disks, partitions)
  File "/tmp/updates/storage/partitioning.py", line 191, in doAutoPartition
    exclusiveDisks=anaconda.id.storage.clearPartDisks)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Attempting to remove a partition that is not owned by any disk.
Comment 1 Jesse Keating 2009-03-24 17:56:37 EDT
Created attachment 336555 [details]
Attached traceback automatically from anaconda.
Comment 2 David Lehman 2009-03-24 21:19:09 EDT
This should be fixed in anaconda-11.5.0.37-1.
Comment 3 Chris Lumens 2009-03-24 23:23:00 EDT
*** Bug 492026 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2009-03-25 09:59:18 EDT
*** Bug 492106 has been marked as a duplicate of this bug. ***
Comment 5 Chris Ward 2009-04-06 05:30:31 EDT
~Attention~

This bug appears to pertain to an important F11 feature, EFI, which the Fedora Community will be testing in an upcoming Fedora Test Day. Your participation in the action would be greatly appreciated!

More information:
https://fedoraproject.org/wiki/QA/Test_Days/2009-04-09
https://fedoraproject.org/wiki/Features/EFI
Comment 6 Bug Zapper 2009-06-09 08:36:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.