Bug 492007 - can't mount fstab volumes
can't mount fstab volumes
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-24 18:38 EDT by Ray Todd Stevens
Modified: 2009-04-02 15:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-02 14:27:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
my current fstab (864 bytes, text/plain)
2009-03-24 18:40 EDT, Ray Todd Stevens
no flags Details
working fstab from fedora 10 (806 bytes, text/plain)
2009-03-25 12:06 EDT, Ben Dailey
no flags Details
anaconda storage log (5.67 KB, text/plain)
2009-03-25 12:06 EDT, Ben Dailey
no flags Details
anaconda log (4.19 KB, text/plain)
2009-03-25 12:07 EDT, Ben Dailey
no flags Details
3/26/09 10am EST anaconda log (5.03 KB, text/plain)
2009-03-26 10:20 EDT, Ben Dailey
no flags Details
3/26/09 10am EST storage log (2.35 KB, text/plain)
2009-03-26 10:21 EDT, Ben Dailey
no flags Details
3/26/09 10am EST anaconda dump (43.50 KB, text/plain)
2009-03-26 10:23 EDT, Ben Dailey
no flags Details

  None (edit)
Description Ray Todd Stevens 2009-03-24 18:38:41 EDT
Description of problem:

When I run a preupgrade upgrade to rawhide for testing I have a failure.

This might be related to the fd0 problem already reported, but it doesn't say so, so I am starting a new report.

It goes into the graphic installer and shortly after the fd0 error I get a message that says that it could not mount one of the volumes in /etc/fstab and then it exits.
Comment 1 Ray Todd Stevens 2009-03-24 18:40:23 EDT
Created attachment 336568 [details]
my current fstab

If it helps here is my current fstab
Comment 2 David Lehman 2009-03-24 19:31:26 EDT
If possible, please switch to tty2 (ctl+alt+f2), run 'killall -USR2 anaconda', and then upload /tmp/anacdump.txt as an attachment to this bug.
Comment 3 Chris Lumens 2009-03-25 10:00:48 EDT
Alternatively, try with anaconda- and see what you get in the error message now.
Comment 4 Ben Dailey 2009-03-25 12:03:36 EDT
I am seeing a similar if not the same problem. Attached are my my fstab, anaconda.log and storage.log. I hope this is the needed information to help track down this bug. Please let me know what else I can help provide or if there is any other testing I can perform.
Comment 5 Ben Dailey 2009-03-25 12:06:08 EDT
Created attachment 336666 [details]
working fstab from fedora 10
Comment 6 Ben Dailey 2009-03-25 12:06:40 EDT
Created attachment 336667 [details]
anaconda storage log
Comment 7 Ben Dailey 2009-03-25 12:07:10 EDT
Created attachment 336668 [details]
anaconda log
Comment 8 Chris Lumens 2009-03-25 12:49:58 EDT
Ben - if you could try today's rawhide too, I think it'd be helpful.  I worked on the error reporting there just a little bit so maybe we can see what line in your fstab is the problem.  Thanks.
Comment 9 Ben Dailey 2009-03-26 10:20:56 EDT
Created attachment 336809 [details]
3/26/09 10am EST anaconda log
Comment 10 Ben Dailey 2009-03-26 10:21:42 EDT
Created attachment 336810 [details]
3/26/09 10am EST storage log
Comment 11 Ben Dailey 2009-03-26 10:23:29 EDT
Created attachment 336811 [details]
3/26/09 10am EST anaconda dump
Comment 12 Ben Dailey 2009-03-26 10:28:04 EDT
Sorry for the duplication in post the anaconda log and storage log wasn't aware they were included at the bottom of the dump text.
Comment 13 Ray Todd Stevens 2009-03-28 12:24:43 EDT
OK I was going to try testing this some more, but the system that I was running the test on now crashes with bug  492705 before we get to this point.   However interestingly enough it appears it might be crashing with some kind of an error relates to reading fstab????
Comment 14 Ray Todd Stevens 2009-04-01 16:53:52 EDT
Well I did a net install upgrade instead of a preupgrade and that seems so far to have worked.   Don't know if that means this is fixed or not.   Right now preupgrade is seriously broken with no real short term expectation that it will be coming back up.
Comment 15 Ray Todd Stevens 2009-04-02 13:55:38 EDT
Have successfully upgraded.   However preupgrade is still broken, so I can't test it the way the problem originally manifested.
Comment 16 Ray Todd Stevens 2009-04-02 15:10:41 EDT
I do wonder if we will not have to reopen this again once preupgrade is fixed so it actually runs.   Although right now it looks more like eventually it should be closed because it fixed itself.

Has anyone gotten this one without using preupgrade?

Note You need to log in before you can comment on or make changes to this bug.