Bug 492016 - [RHEL 5][EPEL] Unable to use Collectd::Unixsock.pm correctly (might be due to FQDN)??
[RHEL 5][EPEL] Unable to use Collectd::Unixsock.pm correctly (might be due to...
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: collectd (Show other bugs)
el5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 19:47 EDT by Issue Tracker
Modified: 2010-10-23 04:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 02:17:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2009-03-24 19:47:08 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-03-24 19:47:13 EDT

-----Original Message-----
From: Florian Forster [mailto:octo@verplant.org] 
Sent: Monday, March 23, 2009 10:54 AM
To: Blatt, Andrew (A&E)
Cc: collectd@verplant.org
Subject: Re: [collectd] Unable to use Collectd::Unixsock.pm correctly (might be due to FQDN)??

* PGP Signed by an unknown key: 03/23/2009 at 10:54:27 AM
Hi Andrew,

On Mon, Mar 23, 2009 at 10:33:07AM -0400, Blatt, Andrew (A&E) wrote:
> I'm trying to use Collectd::Unixsock.pm to get values, and I can't seem
> to get any values back correctly:
> 
> # ./main.pl
> -> GETVAL "upeks1.dev.us.ml.com/load/load"
> <- -1 Type `load"' is unknown.

there is a problem with collectd 4.4 and earlier: Identifiers with
spaces are not handled correctly because `strtok' is used to split up
the command line.

collectd 4.5 and later uses quotes to make identifiers with spaces
possible. Collectd::Unixsock has been changed to make use of this, too.

From your example it looks like you mixed the two: A new version of
Collectd::Unixsock and a pre-4.5 version of collectd (note the
trailing `"').

If you did not mix those versions yourself, please let us know so we can
try to improve the situation :)

Regards,
-octo
-- 
Florian octo Forster
Hacker in training
GnuPG: 0x91523C3D
http://verplant.org/
* Unknown Key
* 0x7434E486


--------------------------------------------------------------------------
This message w/attachments (message) may be privileged, confidential or proprietary, and if you are not an intended recipient, please notify the sender, do not use or share it and delete it. Unless specifically indicated, this message is not an offer to sell or a solicitation of any investment products or other financial product or service, an official confirmation of any transaction, or an official statement of Merrill Lynch. Subject to applicable law, Merrill Lynch may monitor, review and retain e-communications (EC) traveling through its networks/systems. The laws of the country of each sender/recipient may impact the handling of EC, and EC may be archived, supervised and produced in countries other than the country in which you are located. This message cannot be guaranteed to be secure or error-free. References to "Merrill Lynch" are references to any company in the Merrill Lynch & Co., Inc. group of companies, which are wholly-owned by Bank of America Corporation. Securities and Insurance Products: * Are Not FDIC Insured * Are Not Bank Guaranteed * May Lose Value * Are Not a Bank Deposit * Are Not a Condition to Any Banking Service or Activity * Are Not Insured by Any Federal Government Agency. Attachments that are part of this E-communication may have additional important disclosures and disclaimers, which you should read. This message is subject to terms available at the following link: http://www.ml.com/e-communications_terms/. By messaging with Merrill Lynch you consent to the foregoing.
--------------------------------------------------------------------------
 


This event sent from IssueTracker by vanhoof  [Merrill Lynch]
 issue 279200
Comment 3 Chris Van Hoof 2009-03-24 19:50:13 EDT
Talking with Alan today we spoke about bumping EPEL's release of collectd to 4.5.3, which will resolve an issue that was reported to me in EPEL's current 4.4 release.  Alan asked me to file a bug for this request.

Please let me know if anyone needs anything.

--chris
Comment 4 Lubomir Rintel 2009-03-25 03:32:12 EDT
Yo,

collectd-4.5.3-2.el5.1 was build and will hit epel-testing in some time. You can grab it from the plague staging area [1] if you wish to test it before it hits the repository.

[1] http://buildsys.fedoraproject.org/plague-results/fedora-5-epel/collectd/4.5.3-2.el5.1/

Please let me know if it fixes the issue for you.
Comment 5 Chris Van Hoof 2009-04-01 12:41:39 EDT
(In reply to comment #4)
> Yo,
> 
> collectd-4.5.3-2.el5.1 was build and will hit epel-testing in some time. You
> can grab it from the plague staging area [1] if you wish to test it before it
> hits the repository.
> 
> [1]
> http://buildsys.fedoraproject.org/plague-results/fedora-5-epel/collectd/4.5.3-2.el5.1/
> 
> Please let me know if it fixes the issue for you.  

Thanks!  All set.

--chris

Note You need to log in before you can comment on or make changes to this bug.